sleep in control plane thread
[dpdk.git] / app / meson.build
index 8bdf4f5..71109cc 100644 (file)
@@ -1,24 +1,28 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
+
+if is_windows
+       subdir_done()
+endif
 
 apps = [
        'pdump',
        'proc-info',
+       'test-acl',
        'test-bbdev',
        'test-cmdline',
        'test-compress-perf',
        'test-crypto-perf',
        'test-eventdev',
-       'test-pmd']
+       'test-pipeline',
+       'test-pmd',
+       'test-sad']
 
 # for BSD only
 lib_execinfo = cc.find_library('execinfo', required: false)
 
 default_cflags = machine_args
 
-# specify -D_GNU_SOURCE unconditionally
-default_cflags += '-D_GNU_SOURCE'
-
 foreach app:apps
        build = true
        name = app
@@ -63,3 +67,6 @@ foreach app:apps
                                install: true)
        endif
 endforeach
+
+# special case the autotests
+subdir('test')