examples/fips_validation: fix buffer overflow
[dpdk.git] / app / meson.build
index 3a34ebb..eb74f21 100644 (file)
@@ -1,5 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
+
+if is_windows
+       subdir_done()
+endif
 
 apps = [
        'pdump',
@@ -10,20 +14,21 @@ apps = [
        'test-compress-perf',
        'test-crypto-perf',
        'test-eventdev',
-       'test-pmd']
+       'test-fib',
+       'test-flow-perf',
+       'test-pipeline',
+       'test-pmd',
+       'test-regex',
+       'test-sad']
 
 # for BSD only
 lib_execinfo = cc.find_library('execinfo', required: false)
 
-default_cflags = machine_args
-
-# specify -D_GNU_SOURCE unconditionally
-default_cflags += '-D_GNU_SOURCE'
+default_cflags = machine_args + ['-DALLOW_EXPERIMENTAL_API']
 
 foreach app:apps
        build = true
        name = app
-       allow_experimental_apis = false
        sources = []
        includes = []
        cflags = default_cflags
@@ -33,7 +38,7 @@ foreach app:apps
        # use "deps" for internal DPDK dependencies, and "ext_deps" for
        # external package/library requirements
        ext_deps = []
-       deps = dpdk_app_link_libraries
+       deps = []
 
        subdir(name)
 
@@ -50,10 +55,6 @@ foreach app:apps
                        link_libs = dpdk_static_libraries + dpdk_drivers
                endif
 
-               if allow_experimental_apis
-                       cflags += '-DALLOW_EXPERIMENTAL_API'
-               endif
-
                executable('dpdk-' + name,
                                sources,
                                c_args: cflags,
@@ -64,3 +65,6 @@ foreach app:apps
                                install: true)
        endif
 endforeach
+
+# special case the autotests
+subdir('test')