build: remove architecture flag as default C flag
[dpdk.git] / app / test-pmd / meson.build
index a242703..4614e35 100644 (file)
@@ -45,7 +45,7 @@ endif
 
 executable('dpdk-testpmd',
        sources,
-       c_args: '-DALLOW_EXPERIMENTAL_API',
+       c_args: [machine_arg, '-DALLOW_EXPERIMENTAL_API'],
        link_whole: link_libs,
        dependencies: dep_objs,
        install_rpath: join_paths(get_option('prefix'), driver_install_path),