test/ipsec: add performance cases
[dpdk.git] / app / test / meson.build
index 97ad822..1715ddb 100644 (file)
@@ -51,6 +51,8 @@ test_sources = files('commands.c',
        'test_fib6_perf.c',
        'test_func_reentrancy.c',
        'test_flow_classify.c',
+       'test_graph.c',
+       'test_graph_perf.c',
        'test_hash.c',
        'test_hash_functions.c',
        'test_hash_multiwriter.c',
@@ -58,12 +60,12 @@ test_sources = files('commands.c',
        'test_hash_perf.c',
        'test_hash_readwrite_lf_perf.c',
        'test_interrupts.c',
+        'test_ipfrag.c',
        'test_ipsec.c',
        'test_ipsec_sad.c',
+       'test_ipsec_perf.c',
        'test_kni.c',
        'test_kvargs.c',
-       'test_link_bonding.c',
-       'test_link_bonding_rssconf.c',
        'test_logs.c',
        'test_lpm.c',
        'test_lpm6.c',
@@ -101,11 +103,14 @@ test_sources = files('commands.c',
        'test_rib6.c',
        'test_ring.c',
        'test_ring_mpmc_stress.c',
+       'test_ring_hts_stress.c',
+       'test_ring_peek_stress.c',
        'test_ring_perf.c',
        'test_ring_rts_stress.c',
        'test_ring_stress.c',
        'test_rwlock.c',
        'test_sched.c',
+       'test_security.c',
        'test_service_cores.c',
        'test_spinlock.c',
        'test_stack.c',
@@ -124,11 +129,16 @@ test_sources = files('commands.c',
        'test_timer_racecond.c',
        'test_timer_secondary.c',
        'test_ticketlock.c',
+       'test_trace.c',
+       'test_trace_register.c',
+       'test_trace_perf.c',
        'test_version.c',
        'virtual_pmd.c'
 )
 
 test_deps = ['acl',
+       'bus_pci',
+       'bus_vdev',
        'bitratestats',
        'bpf',
        'cfgfile',
@@ -140,12 +150,14 @@ test_deps = ['acl',
        'eventdev',
        'fib',
        'flow_classify',
+       'graph',
        'hash',
        'ipsec',
        'latencystats',
        'lpm',
        'member',
        'metrics',
+       'node',
        'pipeline',
        'port',
        'rawdev',
@@ -153,6 +165,7 @@ test_deps = ['acl',
        'reorder',
        'rib',
        'ring',
+       'security',
        'stack',
        'timer'
 ]
@@ -190,6 +203,7 @@ fast_tests = [
         ['flow_classify_autotest', false],
         ['hash_autotest', true],
         ['interrupt_autotest', true],
+        ['ipfrag_autotest', false],
         ['logs_autotest', true],
         ['lpm_autotest', true],
         ['lpm6_autotest', true],
@@ -214,6 +228,7 @@ fast_tests = [
         ['rwlock_rds_wrm_autotest', true],
         ['rwlock_rde_wro_autotest', true],
         ['sched_autotest', true],
+               ['security_autotest', false],
         ['spinlock_autotest', true],
         ['stack_autotest', false],
         ['stack_lf_autotest', false],
@@ -240,6 +255,7 @@ fast_tests = [
         ['reorder_autotest', true],
         ['service_autotest', true],
         ['thash_autotest', true],
+        ['trace_autotest', true],
 ]
 
 perf_test_names = [
@@ -275,6 +291,8 @@ perf_test_names = [
         'rand_perf_autotest',
         'hash_readwrite_perf_autotest',
         'hash_readwrite_lf_perf_autotest',
+        'trace_perf_autotest',
+       'ipsec_perf_autotest',
 ]
 
 driver_test_names = [
@@ -294,8 +312,6 @@ driver_test_names = [
         'cryptodev_sw_zuc_autotest',
         'eventdev_selftest_octeontx',
         'eventdev_selftest_sw',
-        'link_bonding_autotest',
-        'link_bonding_rssconf_autotest',
         'rawdev_autotest',
 ]
 
@@ -323,11 +339,17 @@ endif
 if dpdk_conf.has('RTE_LIBRTE_SKELETON_EVENTDEV_PMD')
        test_deps += 'pmd_skeleton_event'
 endif
+if dpdk_conf.has('RTE_LIBRTE_TELEMETRY')
+       test_sources += 'test_telemetry_json.c'
+       fast_tests += [['telemetry_json_autotest', true]]
+endif
 
 # The following linkages of drivers are required because
 # they are used via a driver-specific API.
 if dpdk_conf.has('RTE_LIBRTE_BOND_PMD')
        test_deps += 'pmd_bond'
+       test_sources += ['test_link_bonding.c', 'test_link_bonding_rssconf.c']
+       driver_test_names += ['link_bonding_autotest', 'link_bonding_rssconf_autotest']
 endif
 if dpdk_conf.has('RTE_LIBRTE_RING_PMD')
        test_deps += 'pmd_ring'
@@ -364,6 +386,8 @@ endif
 
 # specify -D_GNU_SOURCE unconditionally
 cflags += '-D_GNU_SOURCE'
+# Strict-aliasing rules are violated by uint8_t[] to context size casts.
+cflags += '-fno-strict-aliasing'
 
 test_dep_objs = []
 if dpdk_conf.has('RTE_LIBRTE_COMPRESSDEV')
@@ -387,13 +411,15 @@ endforeach
 test_dep_objs += cc.find_library('execinfo', required: false)
 
 link_libs = []
+link_nodes = []
 if get_option('default_library') == 'static'
        link_libs = dpdk_drivers
+       link_nodes = dpdk_graph_nodes
 endif
 
 dpdk_test = executable('dpdk-test',
        test_sources,
-       link_whole: link_libs,
+       link_whole: link_libs + link_nodes,
        dependencies: test_dep_objs,
        c_args: cflags,
        install_rpath: driver_install_path,