test/security: introduce security lib tests
[dpdk.git] / app / test / meson.build
index d15278c..285e71a 100644 (file)
@@ -108,6 +108,7 @@ test_sources = files('commands.c',
        'test_ring_stress.c',
        'test_rwlock.c',
        'test_sched.c',
+       'test_security.c',
        'test_service_cores.c',
        'test_spinlock.c',
        'test_stack.c',
@@ -155,6 +156,7 @@ test_deps = ['acl',
        'reorder',
        'rib',
        'ring',
+       'security',
        'stack',
        'timer'
 ]
@@ -216,6 +218,7 @@ fast_tests = [
         ['rwlock_rds_wrm_autotest', true],
         ['rwlock_rde_wro_autotest', true],
         ['sched_autotest', true],
+               ['security_autotest', false],
         ['spinlock_autotest', true],
         ['stack_autotest', false],
         ['stack_lf_autotest', false],