node: add logging and null node
[dpdk.git] / app / test / meson.build
index 285e71a..f8ed9d8 100644 (file)
@@ -51,6 +51,8 @@ test_sources = files('commands.c',
        'test_fib6_perf.c',
        'test_func_reentrancy.c',
        'test_flow_classify.c',
+       'test_graph.c',
+       'test_graph_perf.c',
        'test_hash.c',
        'test_hash_functions.c',
        'test_hash_multiwriter.c',
@@ -58,6 +60,7 @@ test_sources = files('commands.c',
        'test_hash_perf.c',
        'test_hash_readwrite_lf_perf.c',
        'test_interrupts.c',
+        'test_ipfrag.c',
        'test_ipsec.c',
        'test_ipsec_sad.c',
        'test_kni.c',
@@ -127,6 +130,9 @@ test_sources = files('commands.c',
        'test_timer_racecond.c',
        'test_timer_secondary.c',
        'test_ticketlock.c',
+       'test_trace.c',
+       'test_trace_register.c',
+       'test_trace_perf.c',
        'test_version.c',
        'virtual_pmd.c'
 )
@@ -143,12 +149,14 @@ test_deps = ['acl',
        'eventdev',
        'fib',
        'flow_classify',
+       'graph',
        'hash',
        'ipsec',
        'latencystats',
        'lpm',
        'member',
        'metrics',
+       'node',
        'pipeline',
        'port',
        'rawdev',
@@ -194,6 +202,7 @@ fast_tests = [
         ['flow_classify_autotest', false],
         ['hash_autotest', true],
         ['interrupt_autotest', true],
+        ['ipfrag_autotest', false],
         ['logs_autotest', true],
         ['lpm_autotest', true],
         ['lpm6_autotest', true],
@@ -245,6 +254,7 @@ fast_tests = [
         ['reorder_autotest', true],
         ['service_autotest', true],
         ['thash_autotest', true],
+        ['trace_autotest', true],
 ]
 
 perf_test_names = [
@@ -280,6 +290,7 @@ perf_test_names = [
         'rand_perf_autotest',
         'hash_readwrite_perf_autotest',
         'hash_readwrite_lf_perf_autotest',
+        'trace_perf_autotest',
 ]
 
 driver_test_names = [
@@ -369,6 +380,8 @@ endif
 
 # specify -D_GNU_SOURCE unconditionally
 cflags += '-D_GNU_SOURCE'
+# Strict-aliasing rules are violated by uint8_t[] to context size casts.
+cflags += '-fno-strict-aliasing'
 
 test_dep_objs = []
 if dpdk_conf.has('RTE_LIBRTE_COMPRESSDEV')
@@ -392,13 +405,15 @@ endforeach
 test_dep_objs += cc.find_library('execinfo', required: false)
 
 link_libs = []
+link_nodes = []
 if get_option('default_library') == 'static'
        link_libs = dpdk_drivers
+       link_nodes = dpdk_graph_nodes
 endif
 
 dpdk_test = executable('dpdk-test',
        test_sources,
-       link_whole: link_libs,
+       link_whole: link_libs + link_nodes,
        dependencies: test_dep_objs,
        c_args: cflags,
        install_rpath: driver_install_path,