doc: fix build when sphinx reports version to stderr
[dpdk.git] / buildtools / meson.build
index 32c79c1..04808da 100644 (file)
@@ -1,14 +1,19 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017-2019 Intel Corporation
 
-subdir('pmdinfogen')
-
+pkgconf = find_program('pkg-config', 'pkgconf', required: false)
 pmdinfo = find_program('gen-pmdinfo-cfile.sh')
+list_dir_globs = find_program('list-dir-globs.py')
+check_symbols = find_program('check-symbols.sh')
+ldflags_ibverbs_static = find_program('options-ibverbs-static.sh')
+binutils_avx512_check = find_program('binutils-avx512-check.sh')
 
-# set up map-to-def script using python, either built-in or external
+# set up map-to-win script using python, either built-in or external
 python3 = import('python').find_installation(required: false)
 if python3.found()
-       map_to_def_cmd = [python3, files('map_to_def.py')]
+       py3 = [python3]
 else
-       map_to_def_cmd = ['meson', 'runpython', files('map_to_def.py')]
+       py3 = ['meson', 'runpython']
 endif
+map_to_win_cmd = py3 + files('map_to_win.py')
+sphinx_wrapper = py3 + files('call-sphinx-build.py')