buildtools: detect discrepancies for experimental symbols
[dpdk.git] / buildtools / meson.build
index cdd38ed..32c79c1 100644 (file)
@@ -1,6 +1,14 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
 
 subdir('pmdinfogen')
 
 pmdinfo = find_program('gen-pmdinfo-cfile.sh')
+
+# set up map-to-def script using python, either built-in or external
+python3 = import('python').find_installation(required: false)
+if python3.found()
+       map_to_def_cmd = [python3, files('map_to_def.py')]
+else
+       map_to_def_cmd = ['meson', 'runpython', files('map_to_def.py')]
+endif