doc: rebuild with meson whenever a file changes
[dpdk.git] / buildtools / meson.build
index 6ef2c57..cd1d054 100644 (file)
@@ -10,10 +10,12 @@ check_experimental_syms = find_program('check-experimental-syms.sh')
 # set up map-to-def script using python, either built-in or external
 python3 = import('python').find_installation(required: false)
 if python3.found()
-       map_to_def_cmd = [python3, files('map_to_def.py')]
+       py3 = [python3]
 else
-       map_to_def_cmd = ['meson', 'runpython', files('map_to_def.py')]
+       py3 = ['meson', 'runpython']
 endif
+map_to_def_cmd = py3 + files('map_to_def.py')
+sphinx_wrapper = py3 + files('call-sphinx-build.py')
 
 # stable ABI always starts with "DPDK_"
 is_experimental_cmd = [find_program('grep', 'findstr'), '^DPDK_']