build: check AVX512 rather than binutils version
[dpdk.git] / buildtools / meson.build
index 0d3a42c..cf0048f 100644 (file)
@@ -1,10 +1,22 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017-2019 Intel Corporation
 
-if is_windows
-       subdir_done()
-endif
+pkgconf = find_program('pkg-config', 'pkgconf', required: false)
+pmdinfo = find_program('gen-pmdinfo-cfile.sh')
+list_dir_globs = find_program('list-dir-globs.py')
+check_symbols = find_program('check-symbols.sh')
+ldflags_ibverbs_static = find_program('options-ibverbs-static.sh')
+binutils_avx512_check = find_program('binutils-avx512-check.sh')
 
-subdir('pmdinfogen')
+# set up map-to-win script using python, either built-in or external
+python3 = import('python').find_installation(required: false)
+if python3.found()
+       py3 = [python3]
+else
+       py3 = ['meson', 'runpython']
+endif
+map_to_win_cmd = py3 + files('map_to_win.py')
+sphinx_wrapper = py3 + files('call-sphinx-build.py')
 
-pmdinfo = find_program('gen-pmdinfo-cfile.sh')
+# stable ABI always starts with "DPDK_"
+is_stable_cmd = [find_program('grep', 'findstr'), '^DPDK_']