build: fix ninja install on FreeBSD
[dpdk.git] / config / meson.build
index 2179c68..3678348 100644 (file)
@@ -1,5 +1,53 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
+
+# check the OS is supported, rather than going any further
+supported_exec_envs = ['freebsd', 'linux', 'windows']
+exec_env = host_machine.system()
+if not supported_exec_envs.contains(exec_env)
+       error('unsupported system type "@0@"'.format(exec_env))
+endif
+
+# define a handy variable for checking which OS we have.
+# gives us "is_windows", "is_freebsd" and "is_linux"
+foreach env:supported_exec_envs
+       set_variable('is_' + env, exec_env == env)
+endforeach
+
+# set the major version, which might be used by drivers and libraries
+# depending on the configuration options
+pver = meson.project_version().split('.')
+major_version = '@0@.@1@'.format(pver.get(0), pver.get(1))
+
+# extract all version information into the build configuration
+dpdk_conf.set('RTE_VER_YEAR', pver.get(0).to_int())
+dpdk_conf.set('RTE_VER_MONTH', pver.get(1).to_int())
+if pver.get(2).contains('-rc')
+       rc_ver = pver.get(2).split('-rc')
+       dpdk_conf.set('RTE_VER_MINOR', rc_ver.get(0).to_int())
+       dpdk_conf.set_quoted('RTE_VER_SUFFIX', '-rc')
+       dpdk_conf.set('RTE_VER_RELEASE', rc_ver.get(1).to_int())
+else
+       dpdk_conf.set('RTE_VER_MINOR', pver.get(2).to_int())
+       dpdk_conf.set_quoted('RTE_VER_SUFFIX', '')
+# for actual, non-rc releases, set the release value to 99 to ensure releases
+# have higher version numbers than their respective release candidates
+       dpdk_conf.set('RTE_VER_RELEASE', 99)
+endif
+
+pmd_subdir_opt = get_option('drivers_install_subdir')
+if pmd_subdir_opt.contains('<VERSION>')
+       pmd_subdir_opt = major_version.join(pmd_subdir_opt.split('<VERSION>'))
+endif
+driver_install_path = join_paths(get_option('libdir'), pmd_subdir_opt)
+eal_pmd_path = join_paths(get_option('prefix'), driver_install_path)
+
+# driver .so files often depend upon the bus drivers for their connect bus,
+# e.g. ixgbe depends on librte_bus_pci. This means that the bus drivers need
+# to be in the library path, so symlink the drivers from the main lib directory.
+meson.add_install_script('../buildtools/symlink-drivers-solibs.sh',
+               get_option('libdir'),
+               pmd_subdir_opt)
 
 # set the machine type and cflags for it
 if meson.is_cross_build()
@@ -7,30 +55,72 @@ if meson.is_cross_build()
 else
        machine = get_option('machine')
 endif
+
+# machine type 'default' is special, it defaults to the per arch agreed common
+# minimal baseline needed for DPDK.
+# That might not be the most optimized, but the most portable version while
+# still being able to support the CPU features required for DPDK.
+# This can be bumped up by the DPDK project, but it can never be an
+# invariant like 'native'
+if machine == 'default'
+       if host_machine.cpu_family().startswith('x86')
+               # matches the old pre-meson build systems default
+               machine = 'corei7'
+       elif host_machine.cpu_family().startswith('arm')
+               machine = 'armv7-a'
+       elif host_machine.cpu_family().startswith('aarch')
+               # arm64 manages defaults in config/arm/meson.build
+               machine = 'default'
+       elif host_machine.cpu_family().startswith('ppc')
+               machine = 'power8'
+       endif
+endif
+
 dpdk_conf.set('RTE_MACHINE', machine)
 machine_args = []
-machine_args += '-march=' + machine
+
+# ppc64 does not support -march= at all, use -mcpu and -mtune for that
+if host_machine.cpu_family().startswith('ppc')
+       machine_args += '-mcpu=' + machine
+       machine_args += '-mtune=' + machine
+else
+       machine_args += '-march=' + machine
+endif
 
 toolchain = cc.get_id()
 dpdk_conf.set_quoted('RTE_TOOLCHAIN', toolchain)
 dpdk_conf.set('RTE_TOOLCHAIN_' + toolchain.to_upper(), 1)
 
+dpdk_conf.set('RTE_ARCH_64', cc.sizeof('void *') == 8)
+
+add_project_link_arguments('-Wl,--no-as-needed', language: 'c')
+dpdk_extra_ldflags += '-Wl,--no-as-needed'
+
 # use pthreads
 add_project_link_arguments('-pthread', language: 'c')
 dpdk_extra_ldflags += '-pthread'
 
-# some libs depend on maths lib
-add_project_link_arguments('-lm', language: 'c')
-dpdk_extra_ldflags += '-lm'
+# on some OS, maths functions are in a separate library
+if cc.find_library('libm', required : false).found()
+       # some libs depend on maths lib
+       add_project_link_arguments('-lm', language: 'c')
+       dpdk_extra_ldflags += '-lm'
+endif
 
 # for linux link against dl, for bsd execinfo
-if host_machine.system() == 'linux'
+if is_linux
        link_lib = 'dl'
-else
+elif is_freebsd
        link_lib = 'execinfo'
+else
+       link_lib = ''
+endif
+
+# if link_lib is empty, do not add it to project properties
+if link_lib != ''
+       add_project_link_arguments('-l' + link_lib, language: 'c')
+       dpdk_extra_ldflags += '-l' + link_lib
 endif
-add_project_link_arguments('-l' + link_lib, language: 'c')
-dpdk_extra_ldflags += '-l' + link_lib
 
 # check for libraries used in multiple places in DPDK
 has_libnuma = 0
@@ -43,11 +133,11 @@ if numa_dep.found() and cc.has_header('numaif.h')
 endif
 
 # check for strlcpy
-if host_machine.system() == 'linux' and cc.find_library('bsd',
-               required: false).found() and cc.has_header('bsd/string.h')
-       dpdk_conf.set('RTE_USE_LIBBSD', 1)
-       add_project_link_arguments('-lbsd', language: 'c')
-       dpdk_extra_ldflags += '-lbsd'
+if is_linux
+       libbsd = dependency('libbsd', required: false)
+       if libbsd.found()
+               dpdk_conf.set('RTE_USE_LIBBSD', 1)
+       endif
 endif
 
 # add -include rte_config to cflags
@@ -57,9 +147,12 @@ add_project_arguments('-include', 'rte_config.h', language: 'c')
 warning_flags = [
        '-Wsign-compare',
        '-Wcast-qual',
-       '-Wno-address-of-packed-member',
-       '-Wno-format-truncation'
+       '-Wno-address-of-packed-member'
 ]
+if not dpdk_conf.get('RTE_ARCH_64')
+# for 32-bit, don't warn about casting a 32-bit pointer to 64-bit int - it's fine!!
+       warning_flags += '-Wno-pointer-to-int-cast'
+endif
 foreach arg: warning_flags
        if cc.has_argument(arg)
                add_project_arguments(arg, language: 'c')
@@ -69,16 +162,22 @@ endforeach
 # set other values pulled from the build options
 dpdk_conf.set('RTE_MAX_LCORE', get_option('max_lcores'))
 dpdk_conf.set('RTE_MAX_NUMA_NODES', get_option('max_numa_nodes'))
+dpdk_conf.set('RTE_MAX_ETHPORTS', get_option('max_ethports'))
 dpdk_conf.set('RTE_LIBEAL_USE_HPET', get_option('use_hpet'))
 dpdk_conf.set('RTE_EAL_ALLOW_INV_SOCKET_ID', get_option('allow_invalid_socket_id'))
 # values which have defaults which may be overridden
 dpdk_conf.set('RTE_MAX_VFIO_GROUPS', 64)
+dpdk_conf.set('RTE_DRIVER_MEMPOOL_BUCKET_SIZE_KB', 64)
+dpdk_conf.set('RTE_LIBRTE_DPAA2_USE_PHYS_IOVA', true)
+
 
 compile_time_cpuflags = []
 if host_machine.cpu_family().startswith('x86')
        arch_subdir = 'x86'
 elif host_machine.cpu_family().startswith('arm') or host_machine.cpu_family().startswith('aarch')
        arch_subdir = 'arm'
+elif host_machine.cpu_family().startswith('ppc')
+       arch_subdir = 'ppc_64'
 endif
 subdir(arch_subdir)
 dpdk_conf.set('RTE_COMPILE_TIME_CPUFLAGS', ','.join(compile_time_cpuflags))
@@ -87,3 +186,6 @@ dpdk_conf.set('RTE_COMPILE_TIME_CPUFLAGS', ','.join(compile_time_cpuflags))
 dpdk_conf.set_quoted('RTE_EAL_PMD_PATH', eal_pmd_path)
 
 install_headers('rte_config.h', subdir: get_option('include_subdir_arch'))
+
+# enable VFIO only if it is linux OS
+dpdk_conf.set('RTE_EAL_VFIO', is_linux)