build: fix ninja install on FreeBSD
[dpdk.git] / config / meson.build
index f8aded6..3678348 100644 (file)
@@ -42,6 +42,13 @@ endif
 driver_install_path = join_paths(get_option('libdir'), pmd_subdir_opt)
 eal_pmd_path = join_paths(get_option('prefix'), driver_install_path)
 
+# driver .so files often depend upon the bus drivers for their connect bus,
+# e.g. ixgbe depends on librte_bus_pci. This means that the bus drivers need
+# to be in the library path, so symlink the drivers from the main lib directory.
+meson.add_install_script('../buildtools/symlink-drivers-solibs.sh',
+               get_option('libdir'),
+               pmd_subdir_opt)
+
 # set the machine type and cflags for it
 if meson.is_cross_build()
        machine = host_machine.cpu()