build: change ABI versioning to global
[dpdk.git] / config / meson.build
index 0d25646..3ffb73a 100644 (file)
@@ -18,6 +18,11 @@ endforeach
 # depending on the configuration options
 pver = meson.project_version().split('.')
 major_version = '@0@.@1@'.format(pver.get(0), pver.get(1))
+abi_version = run_command(find_program('cat', 'more'),
+       files('../ABI_VERSION')).stdout().strip()
+# experimental libraries are versioned as 0.majorminor versions, e.g. 0.201
+ever = abi_version.split('.')
+experimental_abi_version = '0.@0@@1@'.format(ever.get(0), ever.get(1))
 
 # extract all version information into the build configuration
 dpdk_conf.set('RTE_VER_YEAR', pver.get(0).to_int())
@@ -37,7 +42,7 @@ endif
 
 pmd_subdir_opt = get_option('drivers_install_subdir')
 if pmd_subdir_opt.contains('<VERSION>')
-       pmd_subdir_opt = major_version.join(pmd_subdir_opt.split('<VERSION>'))
+       pmd_subdir_opt = abi_version.join(pmd_subdir_opt.split('<VERSION>'))
 endif
 driver_install_path = join_paths(get_option('libdir'), pmd_subdir_opt)
 eal_pmd_path = join_paths(get_option('prefix'), driver_install_path)
@@ -94,7 +99,6 @@ dpdk_conf.set('RTE_TOOLCHAIN_' + toolchain.to_upper(), 1)
 dpdk_conf.set('RTE_ARCH_64', cc.sizeof('void *') == 8)
 
 add_project_link_arguments('-Wl,--no-as-needed', language: 'c')
-dpdk_extra_ldflags += '-Wl,--no-as-needed'
 
 # use pthreads
 add_project_link_arguments('-pthread', language: 'c')
@@ -138,14 +142,46 @@ if libbsd.found()
        dpdk_conf.set('RTE_USE_LIBBSD', 1)
 endif
 
+# check for pcap
+pcap_dep = dependency('pcap', required: false)
+if pcap_dep.found()
+       # pcap got a pkg-config file only in 1.9.0 and before that meson uses
+       # an internal pcap-config finder, which is not compatible with
+       # cross-compilation, so try to fallback to find_library
+       pcap_dep = cc.find_library('pcap', required: false)
+endif
+if pcap_dep.found() and cc.has_header('pcap.h', dependencies: pcap_dep)
+       dpdk_conf.set('RTE_PORT_PCAP', 1)
+       dpdk_extra_ldflags += '-lpcap'
+endif
+
 # add -include rte_config to cflags
 add_project_arguments('-include', 'rte_config.h', language: 'c')
 
 # enable extra warnings and disable any unwanted warnings
 warning_flags = [
-       '-Wsign-compare',
+       # -Wall is added by meson by default, so add -Wextra only
+       '-Wextra',
+
+       # additional warnings in alphabetical order
        '-Wcast-qual',
-       '-Wno-address-of-packed-member'
+       '-Wdeprecated',
+       '-Wformat-nonliteral',
+       '-Wformat-security',
+       '-Wmissing-declarations',
+       '-Wmissing-prototypes',
+       '-Wnested-externs',
+       '-Wold-style-definition',
+       '-Wpointer-arith',
+       '-Wsign-compare',
+       '-Wstrict-prototypes',
+       '-Wundef',
+       '-Wwrite-strings',
+
+       # globally disabled warnings
+       '-Wno-address-of-packed-member',
+       '-Wno-packed-not-aligned',
+       '-Wno-missing-field-initializers'
 ]
 if not dpdk_conf.get('RTE_ARCH_64')
 # for 32-bit, don't warn about casting a 32-bit pointer to 64-bit int - it's fine!!
@@ -162,7 +198,6 @@ dpdk_conf.set('RTE_MAX_LCORE', get_option('max_lcores'))
 dpdk_conf.set('RTE_MAX_NUMA_NODES', get_option('max_numa_nodes'))
 dpdk_conf.set('RTE_MAX_ETHPORTS', get_option('max_ethports'))
 dpdk_conf.set('RTE_LIBEAL_USE_HPET', get_option('use_hpet'))
-dpdk_conf.set('RTE_EAL_ALLOW_INV_SOCKET_ID', get_option('allow_invalid_socket_id'))
 # values which have defaults which may be overridden
 dpdk_conf.set('RTE_MAX_VFIO_GROUPS', 64)
 dpdk_conf.set('RTE_DRIVER_MEMPOOL_BUCKET_SIZE_KB', 64)
@@ -187,3 +222,24 @@ install_headers('rte_config.h', subdir: get_option('include_subdir_arch'))
 
 # enable VFIO only if it is linux OS
 dpdk_conf.set('RTE_EAL_VFIO', is_linux)
+
+# specify -D_GNU_SOURCE unconditionally
+add_project_arguments('-D_GNU_SOURCE', language: 'c')
+
+# specify -D__BSD_VISIBLE for FreeBSD
+if is_freebsd
+       add_project_arguments('-D__BSD_VISIBLE', language: 'c')
+endif
+
+if get_option('b_lto')
+       if cc.has_argument('-ffat-lto-objects')
+               add_project_arguments('-ffat-lto-objects', language: 'c')
+       else
+               error('compiler does not support fat LTO objects - please turn LTO off')
+       endif
+       # workaround for gcc bug 81440
+       if cc.get_id() == 'gcc' and cc.version().version_compare('<8.0')
+               add_project_arguments('-Wno-lto-type-mismatch', language: 'c')
+               add_project_link_arguments('-Wno-lto-type-mismatch', language: 'c')
+       endif
+endif