test mbuf attach
[dpdk.git] / config / meson.build
index 6c46767..cff8b33 100644 (file)
@@ -14,6 +14,10 @@ foreach env:supported_exec_envs
        set_variable('is_' + env, exec_env == env)
 endforeach
 
+# MS linker requires special treatment.
+# TODO: use cc.get_linker_id() with Meson >= 0.54
+is_ms_linker = is_windows and (cc.get_id() == 'clang')
+
 # set the major version, which might be used by drivers and libraries
 # depending on the configuration options
 pver = meson.project_version().split('.')
@@ -21,18 +25,14 @@ major_version = '@0@.@1@'.format(pver.get(0), pver.get(1))
 abi_version = run_command(find_program('cat', 'more'),
        abi_version_file).stdout().strip()
 
-# Regular libraries have the abi_version as the filename extension
+# Libraries have the abi_version as the filename extension
 # and have the soname be all but the final part of the abi_version.
-# Experimental libraries have soname with '0.major'
-# and the filename suffix as 0.majorminor versions,
-# e.g. v20.1 => librte_stable.so.20.1, librte_experimental.so.0.201
-#    sonames => librte_stable.so.20, librte_experimental.so.0.20
-# e.g. v20.0.1 => librte_stable.so.20.0.1, librte_experimental.so.0.2001
-#      sonames => librte_stable.so.20.0, librte_experimental.so.0.200
+# e.g. v20.1 => librte_foo.so.20.1
+#    sonames => librte_foo.so.20
+# e.g. v20.0.1 => librte_foo.so.20.0.1
+#      sonames => librte_foo.so.20.0
 abi_va = abi_version.split('.')
-stable_so_version = abi_va.length() == 2 ? abi_va[0] : abi_va[0] + '.' + abi_va[1]
-experimental_abi_version = '0.' + ''.join(abi_va)
-experimental_so_version = '0.' + ''.join(stable_so_version.split('.'))
+so_version = abi_va.length() == 2 ? abi_va[0] : abi_va[0] + '.' + abi_va[1]
 
 # extract all version information into the build configuration
 dpdk_conf.set('RTE_VER_YEAR', pver.get(0).to_int())
@@ -108,11 +108,15 @@ dpdk_conf.set('RTE_TOOLCHAIN_' + toolchain.to_upper(), 1)
 
 dpdk_conf.set('RTE_ARCH_64', cc.sizeof('void *') == 8)
 
-add_project_link_arguments('-Wl,--no-as-needed', language: 'c')
+if not is_windows
+       add_project_link_arguments('-Wl,--no-as-needed', language: 'c')
+endif
 
-# use pthreads
-add_project_link_arguments('-pthread', language: 'c')
-dpdk_extra_ldflags += '-pthread'
+# use pthreads if available for the platform
+if not is_windows
+       add_project_link_arguments('-pthread', language: 'c')
+       dpdk_extra_ldflags += '-pthread'
+endif
 
 # on some OS, maths functions are in a separate library
 if cc.find_library('m', required : false).found()
@@ -165,6 +169,13 @@ if pcap_dep.found() and cc.has_header('pcap.h', dependencies: pcap_dep)
        dpdk_extra_ldflags += '-lpcap'
 endif
 
+# for clang 32-bit compiles we need libatomic for 64-bit atomic ops
+if cc.get_id() == 'clang' and dpdk_conf.get('RTE_ARCH_64') == false
+       atomic_dep = cc.find_library('atomic', required: true)
+       add_project_link_arguments('-latomic', language: 'c')
+       dpdk_extra_ldflags += '-latomic'
+endif
+
 # add -include rte_config to cflags
 add_project_arguments('-include', 'rte_config.h', language: 'c')
 
@@ -193,6 +204,10 @@ warning_flags = [
        '-Wno-packed-not-aligned',
        '-Wno-missing-field-initializers'
 ]
+if cc.get_id() == 'gcc' and cc.version().version_compare('>=10.0')
+# FIXME: Bugzilla 396
+       warning_flags += '-Wno-zero-length-bounds'
+endif
 if not dpdk_conf.get('RTE_ARCH_64')
 # for 32-bit, don't warn about casting a 32-bit pointer to 64-bit int - it's fine!!
        warning_flags += '-Wno-pointer-to-int-cast'
@@ -214,20 +229,19 @@ dpdk_conf.set('RTE_MAX_LCORE', get_option('max_lcores'))
 dpdk_conf.set('RTE_MAX_NUMA_NODES', get_option('max_numa_nodes'))
 dpdk_conf.set('RTE_MAX_ETHPORTS', get_option('max_ethports'))
 dpdk_conf.set('RTE_LIBEAL_USE_HPET', get_option('use_hpet'))
+dpdk_conf.set('RTE_ENABLE_TRACE_FP', get_option('enable_trace_fp'))
 # values which have defaults which may be overridden
 dpdk_conf.set('RTE_MAX_VFIO_GROUPS', 64)
 dpdk_conf.set('RTE_DRIVER_MEMPOOL_BUCKET_SIZE_KB', 64)
 dpdk_conf.set('RTE_LIBRTE_DPAA2_USE_PHYS_IOVA', true)
+if dpdk_conf.get('RTE_ARCH_64')
+       dpdk_conf.set('RTE_MAX_MEM_MB', 524288)
+else # for 32-bit we need smaller reserved memory areas
+       dpdk_conf.set('RTE_MAX_MEM_MB', 2048)
+endif
 
 
 compile_time_cpuflags = []
-if host_machine.cpu_family().startswith('x86')
-       arch_subdir = 'x86'
-elif host_machine.cpu_family().startswith('arm') or host_machine.cpu_family().startswith('aarch')
-       arch_subdir = 'arm'
-elif host_machine.cpu_family().startswith('ppc')
-       arch_subdir = 'ppc_64'
-endif
 subdir(arch_subdir)
 dpdk_conf.set('RTE_COMPILE_TIME_CPUFLAGS', ','.join(compile_time_cpuflags))
 
@@ -247,6 +261,25 @@ if is_freebsd
        add_project_arguments('-D__BSD_VISIBLE', language: 'c')
 endif
 
+if is_windows
+       # VirtualAlloc2() is available since Windows 10 / Server 2016.
+       add_project_arguments('-D_WIN32_WINNT=0x0A00', language: 'c')
+
+       # Use MinGW-w64 stdio, because DPDK assumes ANSI-compliant formatting.
+       if cc.get_id() == 'gcc'
+               add_project_arguments('-D__USE_MINGW_ANSI_STDIO', language: 'c')
+       endif
+
+       # Contrary to docs, VirtualAlloc2() is exported by mincore.lib
+       # in Windows SDK, while MinGW exports it by advapi32.a.
+       if is_ms_linker
+               add_project_link_arguments('-lmincore', language: 'c')
+       endif
+
+       add_project_link_arguments('-ladvapi32', '-lsetupapi', language: 'c')
+       add_project_link_arguments('-ldbghelp', language: 'c')
+endif
+
 if get_option('b_lto')
        if cc.has_argument('-ffat-lto-objects')
                add_project_arguments('-ffat-lto-objects', language: 'c')