trace: introduce new subsystem
[dpdk.git] / config / meson.build
index b91778e..e851b40 100644 (file)
@@ -1,5 +1,72 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
+
+# check the OS is supported, rather than going any further
+supported_exec_envs = ['freebsd', 'linux', 'windows']
+exec_env = host_machine.system()
+if not supported_exec_envs.contains(exec_env)
+       error('unsupported system type "@0@"'.format(exec_env))
+endif
+
+# define a handy variable for checking which OS we have.
+# gives us "is_windows", "is_freebsd" and "is_linux"
+foreach env:supported_exec_envs
+       set_variable('is_' + env, exec_env == env)
+endforeach
+
+# MS linker requires special treatment.
+# TODO: use cc.get_linker_id() with Meson >= 0.54
+is_ms_linker = is_windows and (cc.get_id() == 'clang')
+
+# set the major version, which might be used by drivers and libraries
+# depending on the configuration options
+pver = meson.project_version().split('.')
+major_version = '@0@.@1@'.format(pver.get(0), pver.get(1))
+abi_version = run_command(find_program('cat', 'more'),
+       abi_version_file).stdout().strip()
+
+# Regular libraries have the abi_version as the filename extension
+# and have the soname be all but the final part of the abi_version.
+# Experimental libraries have soname with '0.major'
+# and the filename suffix as 0.majorminor versions,
+# e.g. v20.1 => librte_stable.so.20.1, librte_experimental.so.0.201
+#    sonames => librte_stable.so.20, librte_experimental.so.0.20
+# e.g. v20.0.1 => librte_stable.so.20.0.1, librte_experimental.so.0.2001
+#      sonames => librte_stable.so.20.0, librte_experimental.so.0.200
+abi_va = abi_version.split('.')
+stable_so_version = abi_va.length() == 2 ? abi_va[0] : abi_va[0] + '.' + abi_va[1]
+experimental_abi_version = '0.' + abi_va[0] + abi_va[1] + '.' + abi_va[2]
+experimental_so_version = experimental_abi_version
+
+# extract all version information into the build configuration
+dpdk_conf.set('RTE_VER_YEAR', pver.get(0).to_int())
+dpdk_conf.set('RTE_VER_MONTH', pver.get(1).to_int())
+if pver.get(2).contains('-rc')
+       rc_ver = pver.get(2).split('-rc')
+       dpdk_conf.set('RTE_VER_MINOR', rc_ver.get(0).to_int())
+       dpdk_conf.set_quoted('RTE_VER_SUFFIX', '-rc')
+       dpdk_conf.set('RTE_VER_RELEASE', rc_ver.get(1).to_int())
+else
+       dpdk_conf.set('RTE_VER_MINOR', pver.get(2).to_int())
+       dpdk_conf.set_quoted('RTE_VER_SUFFIX', '')
+# for actual, non-rc releases, set the release value to 99 to ensure releases
+# have higher version numbers than their respective release candidates
+       dpdk_conf.set('RTE_VER_RELEASE', 99)
+endif
+
+pmd_subdir_opt = get_option('drivers_install_subdir')
+if pmd_subdir_opt.contains('<VERSION>')
+       pmd_subdir_opt = abi_version.join(pmd_subdir_opt.split('<VERSION>'))
+endif
+driver_install_path = join_paths(get_option('libdir'), pmd_subdir_opt)
+eal_pmd_path = join_paths(get_option('prefix'), driver_install_path)
+
+# driver .so files often depend upon the bus drivers for their connect bus,
+# e.g. ixgbe depends on librte_bus_pci. This means that the bus drivers need
+# to be in the library path, so symlink the drivers from the main lib directory.
+meson.add_install_script('../buildtools/symlink-drivers-solibs.sh',
+               get_option('libdir'),
+               pmd_subdir_opt)
 
 # set the machine type and cflags for it
 if meson.is_cross_build()
@@ -45,25 +112,37 @@ dpdk_conf.set('RTE_TOOLCHAIN_' + toolchain.to_upper(), 1)
 
 dpdk_conf.set('RTE_ARCH_64', cc.sizeof('void *') == 8)
 
-add_project_link_arguments('-Wl,--no-as-needed', language: 'c')
-dpdk_extra_ldflags += '-Wl,--no-as-needed'
+if not is_windows
+       add_project_link_arguments('-Wl,--no-as-needed', language: 'c')
+endif
 
-# use pthreads
-add_project_link_arguments('-pthread', language: 'c')
-dpdk_extra_ldflags += '-pthread'
+# use pthreads if available for the platform
+if not is_ms_linker
+       add_project_link_arguments('-pthread', language: 'c')
+       dpdk_extra_ldflags += '-pthread'
+endif
 
-# some libs depend on maths lib
-add_project_link_arguments('-lm', language: 'c')
-dpdk_extra_ldflags += '-lm'
+# on some OS, maths functions are in a separate library
+if cc.find_library('m', required : false).found()
+       # some libs depend on maths lib
+       add_project_link_arguments('-lm', language: 'c')
+       dpdk_extra_ldflags += '-lm'
+endif
 
 # for linux link against dl, for bsd execinfo
-if host_machine.system() == 'linux'
+if is_linux
        link_lib = 'dl'
-else
+elif is_freebsd
        link_lib = 'execinfo'
+else
+       link_lib = ''
+endif
+
+# if link_lib is empty, do not add it to project properties
+if link_lib != ''
+       add_project_link_arguments('-l' + link_lib, language: 'c')
+       dpdk_extra_ldflags += '-l' + link_lib
 endif
-add_project_link_arguments('-l' + link_lib, language: 'c')
-dpdk_extra_ldflags += '-l' + link_lib
 
 # check for libraries used in multiple places in DPDK
 has_libnuma = 0
@@ -75,12 +154,30 @@ if numa_dep.found() and cc.has_header('numaif.h')
        dpdk_extra_ldflags += '-lnuma'
 endif
 
-# check for strlcpy
-if host_machine.system() == 'linux' and cc.find_library('bsd',
-               required: false).found() and cc.has_header('bsd/string.h')
+# check for libbsd
+libbsd = dependency('libbsd', required: false)
+if libbsd.found()
        dpdk_conf.set('RTE_USE_LIBBSD', 1)
-       add_project_link_arguments('-lbsd', language: 'c')
-       dpdk_extra_ldflags += '-lbsd'
+endif
+
+# check for pcap
+pcap_dep = dependency('pcap', required: false)
+if pcap_dep.found()
+       # pcap got a pkg-config file only in 1.9.0 and before that meson uses
+       # an internal pcap-config finder, which is not compatible with
+       # cross-compilation, so try to fallback to find_library
+       pcap_dep = cc.find_library('pcap', required: false)
+endif
+if pcap_dep.found() and cc.has_header('pcap.h', dependencies: pcap_dep)
+       dpdk_conf.set('RTE_PORT_PCAP', 1)
+       dpdk_extra_ldflags += '-lpcap'
+endif
+
+# for clang 32-bit compiles we need libatomic for 64-bit atomic ops
+if cc.get_id() == 'clang' and dpdk_conf.get('RTE_ARCH_64') == false
+       atomic_dep = cc.find_library('atomic', required: true)
+       add_project_link_arguments('-latomic', language: 'c')
+       dpdk_extra_ldflags += '-latomic'
 endif
 
 # add -include rte_config to cflags
@@ -88,14 +185,39 @@ add_project_arguments('-include', 'rte_config.h', language: 'c')
 
 # enable extra warnings and disable any unwanted warnings
 warning_flags = [
-       '-Wsign-compare',
+       # -Wall is added by meson by default, so add -Wextra only
+       '-Wextra',
+
+       # additional warnings in alphabetical order
        '-Wcast-qual',
-       '-Wno-address-of-packed-member'
+       '-Wdeprecated',
+       '-Wformat-nonliteral',
+       '-Wformat-security',
+       '-Wmissing-declarations',
+       '-Wmissing-prototypes',
+       '-Wnested-externs',
+       '-Wold-style-definition',
+       '-Wpointer-arith',
+       '-Wsign-compare',
+       '-Wstrict-prototypes',
+       '-Wundef',
+       '-Wwrite-strings',
+
+       # globally disabled warnings
+       '-Wno-address-of-packed-member',
+       '-Wno-packed-not-aligned',
+       '-Wno-missing-field-initializers'
 ]
 if not dpdk_conf.get('RTE_ARCH_64')
 # for 32-bit, don't warn about casting a 32-bit pointer to 64-bit int - it's fine!!
        warning_flags += '-Wno-pointer-to-int-cast'
 endif
+if cc.get_id() == 'intel'
+       warning_ids = [188, 2203, 2279, 2557, 3179, 3656]
+       foreach i:warning_ids
+               warning_flags += '-diag-disable=@0@'.format(i)
+       endforeach
+endif
 foreach arg: warning_flags
        if cc.has_argument(arg)
                add_project_arguments(arg, language: 'c')
@@ -107,7 +229,7 @@ dpdk_conf.set('RTE_MAX_LCORE', get_option('max_lcores'))
 dpdk_conf.set('RTE_MAX_NUMA_NODES', get_option('max_numa_nodes'))
 dpdk_conf.set('RTE_MAX_ETHPORTS', get_option('max_ethports'))
 dpdk_conf.set('RTE_LIBEAL_USE_HPET', get_option('use_hpet'))
-dpdk_conf.set('RTE_EAL_ALLOW_INV_SOCKET_ID', get_option('allow_invalid_socket_id'))
+dpdk_conf.set('RTE_ENABLE_TRACE_FP', get_option('enable_trace_fp'))
 # values which have defaults which may be overridden
 dpdk_conf.set('RTE_MAX_VFIO_GROUPS', 64)
 dpdk_conf.set('RTE_DRIVER_MEMPOOL_BUCKET_SIZE_KB', 64)
@@ -120,7 +242,7 @@ if host_machine.cpu_family().startswith('x86')
 elif host_machine.cpu_family().startswith('arm') or host_machine.cpu_family().startswith('aarch')
        arch_subdir = 'arm'
 elif host_machine.cpu_family().startswith('ppc')
-       arch_subdir = 'ppc_64'
+       arch_subdir = 'ppc'
 endif
 subdir(arch_subdir)
 dpdk_conf.set('RTE_COMPILE_TIME_CPUFLAGS', ','.join(compile_time_cpuflags))
@@ -131,4 +253,35 @@ dpdk_conf.set_quoted('RTE_EAL_PMD_PATH', eal_pmd_path)
 install_headers('rte_config.h', subdir: get_option('include_subdir_arch'))
 
 # enable VFIO only if it is linux OS
-dpdk_conf.set('RTE_EAL_VFIO', host_machine.system() == 'linux')
+dpdk_conf.set('RTE_EAL_VFIO', is_linux)
+
+# specify -D_GNU_SOURCE unconditionally
+add_project_arguments('-D_GNU_SOURCE', language: 'c')
+
+# specify -D__BSD_VISIBLE for FreeBSD
+if is_freebsd
+       add_project_arguments('-D__BSD_VISIBLE', language: 'c')
+endif
+
+if is_windows
+       # Minimum supported API is Windows 7.
+       add_project_arguments('-D_WIN32_WINNT=0x0601', language: 'c')
+
+       # Use MinGW-w64 stdio, because DPDK assumes ANSI-compliant formatting.
+       if cc.get_id() == 'gcc'
+               add_project_arguments('-D__USE_MINGW_ANSI_STDIO', language: 'c')
+       endif
+endif
+
+if get_option('b_lto')
+       if cc.has_argument('-ffat-lto-objects')
+               add_project_arguments('-ffat-lto-objects', language: 'c')
+       else
+               error('compiler does not support fat LTO objects - please turn LTO off')
+       endif
+       # workaround for gcc bug 81440
+       if cc.get_id() == 'gcc' and cc.version().version_compare('<8.0')
+               add_project_arguments('-Wno-lto-type-mismatch', language: 'c')
+               add_project_link_arguments('-Wno-lto-type-mismatch', language: 'c')
+       endif
+endif