build: check AVX512 rather than binutils version
[dpdk.git] / config / x86 / meson.build
index adc857b..6ec020e 100644 (file)
@@ -3,14 +3,10 @@
 
 # get binutils version for the workaround of Bug 97
 if not is_windows
-       ldver = run_command('ld', '-v').stdout().strip()
-       if ldver.contains('2.30') and cc.has_argument('-mno-avx512f')
+       binutils_ok = run_command(binutils_avx512_check)
+       if binutils_ok.returncode() != 0 and cc.has_argument('-mno-avx512f')
                machine_args += '-mno-avx512f'
-               message('Binutils 2.30 detected, disabling AVX512 support as workaround for bug #97')
-       endif
-       if ldver.contains('2.31') and cc.has_argument('-mno-avx512f')
-               machine_args += '-mno-avx512f'
-               message('Binutils 2.31 detected, disabling AVX512 support as workaround for bug #249')
+               warning('Binutils error with AVX512 assembly, disabling AVX512 support')
        endif
 endif