mk: build with _GNU_SOURCE defined by default
[dpdk.git] / drivers / bus / fslmc / meson.build
index 54ca92d..4b05215 100644 (file)
@@ -7,7 +7,7 @@ if host_machine.system() != 'linux'
         build = false
 endif
 
-deps += ['eventdev', 'kvargs']
+deps += ['common_dpaax', 'eventdev', 'kvargs']
 sources = files('fslmc_bus.c',
                'fslmc_vfio.c',
                'mc/dpbp.c',
@@ -26,4 +26,3 @@ sources = files('fslmc_bus.c',
 allow_experimental_apis = true
 
 includes += include_directories('mc', 'qbman/include', 'portal')
-cflags += ['-D_GNU_SOURCE']