mk: build with _GNU_SOURCE defined by default
[dpdk.git] / drivers / bus / fslmc / meson.build
index e94340e..4b05215 100644 (file)
@@ -1,16 +1,19 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright 2018 NXP
 
+version = 2
+
 if host_machine.system() != 'linux'
         build = false
 endif
 
-deps += ['ethdev', 'eventdev', 'kvargs']
+deps += ['common_dpaax', 'eventdev', 'kvargs']
 sources = files('fslmc_bus.c',
                'fslmc_vfio.c',
                'mc/dpbp.c',
                'mc/dpci.c',
                'mc/dpcon.c',
+               'mc/dpdmai.c',
                'mc/dpio.c',
                'mc/dpmng.c',
                'mc/mc_sys.c',
@@ -22,6 +25,4 @@ sources = files('fslmc_bus.c',
 
 allow_experimental_apis = true
 
-includes += include_directories('../../../lib/librte_eal/linuxapp/eal')
 includes += include_directories('mc', 'qbman/include', 'portal')
-cflags += ['-D_GNU_SOURCE']