common/mlx5: remove NDEBUG
[dpdk.git] / drivers / common / mlx5 / meson.build
index fdd1e85..2b70410 100644 (file)
@@ -60,9 +60,9 @@ if build
                endif
        endforeach
        if get_option('buildtype').contains('debug')
-               cflags += [ '-pedantic', '-UNDEBUG', '-DPEDANTIC' ]
+               cflags += [ '-pedantic', '-DPEDANTIC' ]
        else
-               cflags += [ '-DNDEBUG', '-UPEDANTIC' ]
+               cflags += [ '-UPEDANTIC' ]
        endif
        # To maintain the compatibility with the make build system
        # mlx5_autoconf.h file is still generated.