eal: move common header files
[dpdk.git] / drivers / common / mlx5 / meson.build
index 089494e..f671710 100644 (file)
@@ -8,11 +8,11 @@ if not is_linux
 endif
 
 static_ibverbs = (get_option('ibverbs_link') == 'static')
-pmd_dlopen = (get_option('ibverbs_link') == 'dlopen')
+dlopen_ibverbs = (get_option('ibverbs_link') == 'dlopen')
 LIB_GLUE_BASE = 'librte_pmd_mlx5_glue.so'
 LIB_GLUE_VERSION = '20.02.0'
 LIB_GLUE = LIB_GLUE_BASE + '.' + LIB_GLUE_VERSION
-if pmd_dlopen
+if dlopen_ibverbs
        dpdk_conf.set('RTE_IBVERBS_LINK_DLOPEN', 1)
        cflags += [
                '-DMLX5_GLUE="@0@"'.format(LIB_GLUE),
@@ -29,7 +29,7 @@ foreach libname:libnames
        endif
        if lib.found()
                libs += lib
-               if not static_ibverbs
+               if not static_ibverbs and not dlopen_ibverbs
                        ext_deps += lib
                endif
        else
@@ -38,10 +38,12 @@ foreach libname:libnames
                subdir_done()
        endif
 endforeach
-if static_ibverbs
+if static_ibverbs or dlopen_ibverbs
        # Build without adding shared libs to Requires.private
        ibv_cflags = run_command(pkgconf, '--cflags', 'libibverbs').stdout()
        ext_deps += declare_dependency(compile_args: ibv_cflags.split())
+endif
+if static_ibverbs
        # Add static deps ldflags to internal apps and Libs.private
        ibv_ldflags = run_command(ldflags_ibverbs_static, check:true).stdout()
        ext_deps += declare_dependency(link_args:ibv_ldflags.split())
@@ -54,7 +56,7 @@ sources = files(
        'mlx5_common.c',
        'mlx5_nl.c',
 )
-if not pmd_dlopen
+if not dlopen_ibverbs
        sources += files('mlx5_glue.c')
 endif
 cflags_options = [
@@ -193,7 +195,7 @@ endforeach
 configure_file(output : 'mlx5_autoconf.h', configuration : config)
 
 # Build Glue Library
-if pmd_dlopen
+if dlopen_ibverbs
        dlopen_name = 'mlx5_glue'
        dlopen_lib_name = 'rte_pmd_@0@'.format(dlopen_name)
        dlopen_so_version = LIB_GLUE_VERSION
@@ -201,7 +203,7 @@ if pmd_dlopen
        dlopen_install_dir = [ eal_pmd_path + '-glue' ]
        dlopen_includes = [global_inc]
        dlopen_includes += include_directories(
-               '../../../lib/librte_eal/common/include/generic',
+               '../../../lib/librte_eal/include/generic',
        )
        shared_lib = shared_library(
                dlopen_lib_name,