eal: move common header files
[dpdk.git] / drivers / common / mlx5 / meson.build
index ea98e61..f671710 100644 (file)
@@ -29,7 +29,7 @@ foreach libname:libnames
        endif
        if lib.found()
                libs += lib
-               if not static_ibverbs
+               if not static_ibverbs and not dlopen_ibverbs
                        ext_deps += lib
                endif
        else
@@ -38,10 +38,12 @@ foreach libname:libnames
                subdir_done()
        endif
 endforeach
-if static_ibverbs
+if static_ibverbs or dlopen_ibverbs
        # Build without adding shared libs to Requires.private
        ibv_cflags = run_command(pkgconf, '--cflags', 'libibverbs').stdout()
        ext_deps += declare_dependency(compile_args: ibv_cflags.split())
+endif
+if static_ibverbs
        # Add static deps ldflags to internal apps and Libs.private
        ibv_ldflags = run_command(ldflags_ibverbs_static, check:true).stdout()
        ext_deps += declare_dependency(link_args:ibv_ldflags.split())
@@ -201,7 +203,7 @@ if dlopen_ibverbs
        dlopen_install_dir = [ eal_pmd_path + '-glue' ]
        dlopen_includes = [global_inc]
        dlopen_includes += include_directories(
-               '../../../lib/librte_eal/common/include/generic',
+               '../../../lib/librte_eal/include/generic',
        )
        shared_lib = shared_library(
                dlopen_lib_name,