build: replace meson OS detection with variable
[dpdk.git] / drivers / crypto / octeontx2 / meson.build
index a28c700..0948e73 100644 (file)
@@ -1,8 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright (C) 2019 Marvell International Ltd.
 
-if host_machine.system() != 'linux'
-        build = false
+if not is_linux
+       build = false
+       reason = 'only supported on Linux'
 endif
 
 deps += ['bus_pci']