crypto/zuc: use IPsec library
[dpdk.git] / drivers / crypto / zuc / meson.build
index b231de0..be3824c 100644 (file)
@@ -1,11 +1,22 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2018 Intel Corporation
+# Copyright(c) 2018-2020 Intel Corporation
 
-lib = cc.find_library('sso_zuc', required: false)
-if not lib.found() or not cc.has_header('sso_zuc.h')
+IMB_required_ver = '0.53.0'
+lib = cc.find_library('IPSec_MB', required: false)
+if not lib.found()
        build = false
-       reason = 'missing dependency, "libsso_zuc"'
-       subdir_done()
+       reason = 'missing dependency, "libIPSec_MB"'
+else
+       # version comes with quotes, so we split based on " and take the middle
+       imb_ver = cc.get_define('IMB_VERSION_STR',
+               prefix : '#include<intel-ipsec-mb.h>').split('"')[1]
+
+       if (imb_ver == '') or (imb_ver.version_compare('<' + IMB_required_ver))
+               reason = 'IPSec_MB version >= @0@ is required, found version @1@'.format(
+                               IMB_required_ver, imb_ver)
+               build = false
+       endif
+
 endif
 
 allow_experimental_apis = true