build: remove special versioning for non stable libraries
[dpdk.git] / drivers / meson.build
index ccdc738..161cfda 100644 (file)
@@ -1,10 +1,6 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017-2019 Intel Corporation
 
-if is_windows
-       subdir_done()
-endif
-
 # Defines the order in which the drivers are buit.
 dpdk_driver_classes = ['common',
               'bus',
@@ -125,20 +121,6 @@ foreach class:dpdk_driver_classes
                                                output: out_filename,
                                                depends: [pmdinfogen, tmp_lib])
                        endif
-                       version_map = '@0@/@1@/@2@_version.map'.format(
-                                       meson.current_source_dir(),
-                                       drv_path, lib_name)
-
-                       is_stable = run_command(is_stable_cmd,
-                               files(version_map)).returncode() == 0
-
-                       if is_stable
-                               lib_version = abi_version
-                               so_version = stable_so_version
-                       else
-                               lib_version = experimental_abi_version
-                               so_version = experimental_so_version
-                       endif
 
                        # now build the static driver
                        static_lib = static_library(lib_name,
@@ -156,16 +138,22 @@ foreach class:dpdk_driver_classes
                        implib = 'lib' + lib_name + '.dll.a'
 
                        def_file = custom_target(lib_name + '_def',
-                               command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
+                               command: [map_to_win_cmd, '@INPUT@', '@OUTPUT@'],
                                input: version_map,
                                output: '@0@_exports.def'.format(lib_name))
-                       lk_deps = [version_map, def_file]
+
+                       mingw_map = custom_target(lib_name + '_mingw',
+                               command: [map_to_win_cmd, '@INPUT@', '@OUTPUT@'],
+                               input: version_map,
+                               output: '@0@_mingw.map'.format(lib_name))
+
+                       lk_deps = [version_map, def_file, mingw_map]
                        if is_windows
                                if is_ms_linker
                                        lk_args = ['-Wl,/def:' + def_file.full_path(),
                                                '-Wl,/implib:drivers\\' + implib]
                                else
-                                       lk_args = []
+                                       lk_args = ['-Wl,--version-script=' + mingw_map.full_path()]
                                endif
                        else
                                lk_args = ['-Wl,--version-script=' + version_map]
@@ -188,7 +176,7 @@ foreach class:dpdk_driver_classes
                                c_args: cflags,
                                link_args: lk_args,
                                link_depends: lk_deps,
-                               version: lib_version,
+                               version: abi_version,
                                soversion: so_version,
                                install: true,
                                install_dir: driver_install_path)
@@ -198,7 +186,7 @@ foreach class:dpdk_driver_classes
                        shared_dep = declare_dependency(link_with: shared_lib,
                                        include_directories: includes,
                                        dependencies: shared_deps)
-                       static_dep = declare_dependency(link_with: static_lib,
+                       static_dep = declare_dependency(
                                        include_directories: includes,
                                        dependencies: static_deps)