build: allow using wildcards to disable drivers
[dpdk.git] / drivers / meson.build
index 4a1cb8b..5502bf9 100644 (file)
@@ -9,14 +9,16 @@ endif
 dpdk_driver_classes = ['common',
               'bus',
               'mempool', # depends on common and bus.
-              'net',     # depends on common, bus and mempool.
+              'net',     # depends on common, bus, mempool
+              'raw',     # depends on common, bus and net.
               'crypto',  # depends on common, bus and mempool (net in future).
               'compress', # depends on common, bus, mempool.
+              'vdpa',    # depends on common, bus and mempool.
               'event',   # depends on common, bus, mempool and net.
-              'baseband', # depends on common and bus.
-              'raw']     # depends on common, bus, mempool, net and event.
+              'baseband'] # depends on common and bus.
 
-disabled_drivers = get_option('disable_drivers').split(',')
+disabled_drivers = run_command(list_dir_globs, get_option('disable_drivers'),
+               ).stdout().split()
 
 default_cflags = machine_args
 if cc.has_argument('-Wno-format-truncation')
@@ -41,7 +43,7 @@ foreach class:dpdk_driver_classes
                build = true # set to false to disable, e.g. missing deps
                reason = '<unknown reason>' # set if build == false to explain
                name = drv
-               version = 1
+               fmt_name = ''
                allow_experimental_apis = false
                sources = []
                objs = []
@@ -61,10 +63,15 @@ foreach class:dpdk_driver_classes
                # pull in driver directory which should assign to each of the above
                subdir(drv_path)
 
-               if drv_path in disabled_drivers
-                       build = false
-                       reason = 'Explicitly disabled via build config'
-               elif build
+               # skip disabled drivers. For meson 0.49 change this to use
+               # "in" keyword
+               foreach disable_path: disabled_drivers
+                       if drv_path == disable_path
+                               build = false
+                               reason = 'Explicitly disabled via build config'
+                       endif
+               endforeach
+               if build
                        # get dependency objs from strings
                        shared_deps = ext_deps
                        static_deps = ext_deps
@@ -93,8 +100,11 @@ foreach class:dpdk_driver_classes
                else
                        class_drivers += name
 
-                       dpdk_conf.set(config_flag_fmt.format(name.to_upper()),1)
-                       lib_name = driver_name_fmt.format(name)
+                       if fmt_name == ''
+                               fmt_name = name
+                       endif
+                       dpdk_conf.set(config_flag_fmt.format(fmt_name.to_upper()),1)
+                       lib_name = driver_name_fmt.format(fmt_name)
 
                        if allow_experimental_apis
                                cflags += '-DALLOW_EXPERIMENTAL_API'
@@ -119,12 +129,19 @@ foreach class:dpdk_driver_classes
                                        output: out_filename,
                                        depends: [pmdinfogen, tmp_lib])
 
-                       if get_option('per_library_versions')
-                               lib_version = '@0@.1'.format(version)
-                               so_version = '@0@'.format(version)
+                       version_map = '@0@/@1@/@2@_version.map'.format(
+                                       meson.current_source_dir(),
+                                       drv_path, lib_name)
+
+                       is_experimental = run_command(is_experimental_cmd,
+                               files(version_map)).returncode()
+
+                       if is_experimental != 0
+                               lib_version = experimental_abi_version
+                               so_version = experimental_so_version
                        else
-                               lib_version = major_version
-                               so_version = major_version
+                               lib_version = abi_version
+                               so_version = stable_so_version
                        endif
 
                        # now build the static driver
@@ -140,14 +157,37 @@ foreach class:dpdk_driver_classes
                        version_map = '@0@/@1@/@2@_version.map'.format(
                                        meson.current_source_dir(),
                                        drv_path, lib_name)
+                       implib = dir_name + '.dll.a'
+
+                       def_file = custom_target(lib_name + '_def',
+                               command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
+                               input: version_map,
+                               output: '@0@_exports.def'.format(lib_name))
+                       lk_deps = [version_map, def_file]
+                       if is_windows
+                               lk_args = ['-Wl,/def:' + def_file.full_path(),
+                                       '-Wl,/implib:lib\\' + implib]
+                       else
+                               lk_args = ['-Wl,--version-script=' + version_map]
+                               # on unix systems check the output of the
+                               # experimental syms script, using it as a
+                               # dependency of the .so build
+                               lk_deps += custom_target(lib_name + '.exp_chk',
+                                       command: [check_experimental_syms,
+                                               version_map, '@INPUT@'],
+                                       capture: true,
+                                       input: static_lib,
+                                       output: lib_name + '.exp_chk')
+                       endif
+
                        shared_lib = shared_library(lib_name,
                                sources,
                                objects: objs,
                                include_directories: includes,
                                dependencies: shared_deps,
                                c_args: cflags,
-                               link_args: '-Wl,--version-script=' + version_map,
-                               link_depends: version_map,
+                               link_args: lk_args,
+                               link_depends: lk_deps,
                                version: lib_version,
                                soversion: so_version,
                                install: true,