mk: build with _GNU_SOURCE defined by default
[dpdk.git] / drivers / meson.build
index 451abac..567f4a1 100644 (file)
@@ -1,35 +1,24 @@
-#   BSD LICENSE
-#
-#   Copyright(c) 2017 Intel Corporation.
-#   All rights reserved.
-#
-#   Redistribution and use in source and binary forms, with or without
-#   modification, are permitted provided that the following conditions
-#   are met:
-#
-#     * Redistributions of source code must retain the above copyright
-#       notice, this list of conditions and the following disclaimer.
-#     * Redistributions in binary form must reproduce the above copyright
-#       notice, this list of conditions and the following disclaimer in
-#       the documentation and/or other materials provided with the
-#       distribution.
-#     * Neither the name of Intel Corporation nor the names of its
-#       contributors may be used to endorse or promote products derived
-#       from this software without specific prior written permission.
-#
-#   THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-#   "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-#   LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-#   A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-#   OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-#   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-#   DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-#   THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-#   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-#   OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-driver_classes = ['bus', 'crypto', 'event', 'mempool', 'net']
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+# Defines the order in which the drivers are buit.
+driver_classes = ['common',
+              'bus',
+              'mempool', # depends on common and bus.
+              'net',     # depends on common, bus and mempool.
+              'crypto',  # depends on common, bus and mempool (net in future).
+              'compress', # depends on common, bus, mempool.
+              'event',   # depends on common, bus, mempool and net.
+              'baseband', # depends on common and bus.
+              'raw']     # depends on common, bus, mempool, net and event.
+
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+       default_cflags += '-Wno-format-truncation'
+endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
 
 foreach class:driver_classes
        drivers = []
@@ -40,6 +29,7 @@ foreach class:driver_classes
                             # version file for linking
 
        subdir(class)
+       class_drivers = []
 
        foreach drv:drivers
                drv_path = join_paths(class, drv)
@@ -51,7 +41,7 @@ foreach class:driver_classes
                allow_experimental_apis = false
                sources = []
                objs = []
-               cflags = []
+               cflags = default_cflags
                includes = [include_directories(drv_path)]
                # set up internal deps. Drivers can append/override as necessary
                deps = std_deps
@@ -67,35 +57,46 @@ foreach class:driver_classes
                subdir(drv_path)
 
                if build
+                       class_drivers += name
+
                        dpdk_conf.set(config_flag_fmt.format(name.to_upper()),1)
+                       lib_name = driver_name_fmt.format(name)
 
                        if allow_experimental_apis
                                cflags += '-DALLOW_EXPERIMENTAL_API'
                        endif
 
                        # get dependency objs from strings
-                       dep_objs = []
+                       shared_objs = []
+                       static_objs = []
                        foreach d:deps
-                               dep_objs += [get_variable('dep_rte_' + d)]
+                               if not is_variable('shared_rte_' + d)
+                                       error('Missing dependency ' + d +
+                                               ' for driver ' + lib_name)
+                               endif
+                               shared_objs += [get_variable('shared_rte_' + d)]
+                               static_objs += [get_variable('static_rte_' + d)]
                        endforeach
-                       dep_objs += ext_deps
+                       shared_objs += ext_deps
+                       static_objs += ext_deps
                        dpdk_extra_ldflags += pkgconfig_extra_libs
 
-                       # generate pmdinfo sources
-                       pmdinfogen_srcs = run_command('grep', '--files-with-matches',
-                               'RTE_PMD_REGISTER_.*(.*)', sources).stdout().strip().split()
-                       foreach src: pmdinfogen_srcs
-                               out_filename = '@0@.pmd.c'.format(src.split('/')[-1])
-                               tmp_lib = static_library('tmp_@0@'.format(src.underscorify()),
-                                       src, include_directories: includes,
-                                       dependencies: dep_objs,
+                       # generate pmdinfo sources by building a temporary
+                       # lib and then running pmdinfogen on the contents of
+                       # that lib. The final lib reuses the object files and
+                       # adds in the new source file.
+                       out_filename = lib_name + '.pmd.c'
+                       tmp_lib = static_library('tmp_' + lib_name,
+                                       sources,
+                                       include_directories: includes,
+                                       dependencies: static_objs,
                                        c_args: cflags)
-                               sources += custom_target(out_filename,
-                                               command: [pmdinfo, tmp_lib.full_path(),
-                                                       '@OUTPUT@', pmdinfogen],
-                                               output: out_filename,
-                                               depends: [pmdinfogen, tmp_lib])
-                       endforeach
+                       objs += tmp_lib.extract_all_objects()
+                       sources = custom_target(out_filename,
+                                       command: [pmdinfo, tmp_lib.full_path(),
+                                               '@OUTPUT@', pmdinfogen],
+                                       output: out_filename,
+                                       depends: [pmdinfogen, tmp_lib])
 
                        if get_option('per_library_versions')
                                lib_version = '@0@.1'.format(version)
@@ -107,16 +108,24 @@ foreach class:driver_classes
                                so_version = lib_version
                        endif
 
-                       # now build the driver itself, and add to the drivers list
-                       lib_name = driver_name_fmt.format(name)
+                       # now build the static driver
+                       static_lib = static_library(lib_name,
+                               sources,
+                               objects: objs,
+                               include_directories: includes,
+                               dependencies: static_objs,
+                               c_args: cflags,
+                               install: true)
+
+                       # now build the shared driver
                        version_map = '@0@/@1@/@2@_version.map'.format(
                                        meson.current_source_dir(),
                                        drv_path, lib_name)
-                       lib = library(lib_name,
+                       shared_lib = shared_library(lib_name,
                                sources,
                                objects: objs,
                                include_directories: includes,
-                               dependencies: dep_objs,
+                               dependencies: shared_objs,
                                c_args: cflags,
                                link_args: '-Wl,--version-script=' + version_map,
                                link_depends: version_map,
@@ -125,14 +134,24 @@ foreach class:driver_classes
                                install: true,
                                install_dir: driver_install_path)
 
-                       dpdk_drivers += lib
-
                        # create a dependency object and add it to the global dictionary so
                        # testpmd or other built-in apps can find it if necessary
-                       set_variable('dep_@0@'.format(lib_name),
-                                       declare_dependency(link_with: lib,
+                       shared_dep = declare_dependency(link_with: shared_lib,
                                        include_directories: includes,
-                                       dependencies: dep_objs))
+                                       dependencies: shared_objs)
+                       static_dep = declare_dependency(link_with: static_lib,
+                                       include_directories: includes,
+                                       dependencies: static_objs)
+
+                       dpdk_drivers += static_lib
+
+                       set_variable('shared_@0@'.format(lib_name), shared_dep)
+                       set_variable('static_@0@'.format(lib_name), static_dep)
                endif # build
        endforeach
+
+       if meson.version().version_compare('>=0.47')
+               # prior to 0.47, set_variable can't take array params
+               set_variable(class + '_drivers', class_drivers)
+       endif
 endforeach