mk: build with _GNU_SOURCE defined by default
[dpdk.git] / drivers / meson.build
index 5ee0026..567f4a1 100644 (file)
@@ -1,7 +1,24 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Intel Corporation
 
-driver_classes = ['bus', 'crypto', 'event', 'mempool', 'net']
+# Defines the order in which the drivers are buit.
+driver_classes = ['common',
+              'bus',
+              'mempool', # depends on common and bus.
+              'net',     # depends on common, bus and mempool.
+              'crypto',  # depends on common, bus and mempool (net in future).
+              'compress', # depends on common, bus, mempool.
+              'event',   # depends on common, bus, mempool and net.
+              'baseband', # depends on common and bus.
+              'raw']     # depends on common, bus, mempool, net and event.
+
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+       default_cflags += '-Wno-format-truncation'
+endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
 
 foreach class:driver_classes
        drivers = []
@@ -12,6 +29,7 @@ foreach class:driver_classes
                             # version file for linking
 
        subdir(class)
+       class_drivers = []
 
        foreach drv:drivers
                drv_path = join_paths(class, drv)
@@ -23,7 +41,7 @@ foreach class:driver_classes
                allow_experimental_apis = false
                sources = []
                objs = []
-               cflags = [machine_arg]
+               cflags = default_cflags
                includes = [include_directories(drv_path)]
                # set up internal deps. Drivers can append/override as necessary
                deps = std_deps
@@ -39,7 +57,10 @@ foreach class:driver_classes
                subdir(drv_path)
 
                if build
+                       class_drivers += name
+
                        dpdk_conf.set(config_flag_fmt.format(name.to_upper()),1)
+                       lib_name = driver_name_fmt.format(name)
 
                        if allow_experimental_apis
                                cflags += '-DALLOW_EXPERIMENTAL_API'
@@ -49,6 +70,10 @@ foreach class:driver_classes
                        shared_objs = []
                        static_objs = []
                        foreach d:deps
+                               if not is_variable('shared_rte_' + d)
+                                       error('Missing dependency ' + d +
+                                               ' for driver ' + lib_name)
+                               endif
                                shared_objs += [get_variable('shared_rte_' + d)]
                                static_objs += [get_variable('static_rte_' + d)]
                        endforeach
@@ -56,21 +81,22 @@ foreach class:driver_classes
                        static_objs += ext_deps
                        dpdk_extra_ldflags += pkgconfig_extra_libs
 
-                       # generate pmdinfo sources
-                       pmdinfogen_srcs = run_command('grep', '--files-with-matches',
-                               'RTE_PMD_REGISTER_.*(.*)', sources).stdout().strip().split()
-                       foreach src: pmdinfogen_srcs
-                               out_filename = '@0@.pmd.c'.format(src.split('/')[-1])
-                               tmp_lib = static_library('tmp_@0@'.format(src.underscorify()),
-                                       src, include_directories: includes,
+                       # generate pmdinfo sources by building a temporary
+                       # lib and then running pmdinfogen on the contents of
+                       # that lib. The final lib reuses the object files and
+                       # adds in the new source file.
+                       out_filename = lib_name + '.pmd.c'
+                       tmp_lib = static_library('tmp_' + lib_name,
+                                       sources,
+                                       include_directories: includes,
                                        dependencies: static_objs,
                                        c_args: cflags)
-                               sources += custom_target(out_filename,
-                                               command: [pmdinfo, tmp_lib.full_path(),
-                                                       '@OUTPUT@', pmdinfogen],
-                                               output: out_filename,
-                                               depends: [pmdinfogen, tmp_lib])
-                       endforeach
+                       objs += tmp_lib.extract_all_objects()
+                       sources = custom_target(out_filename,
+                                       command: [pmdinfo, tmp_lib.full_path(),
+                                               '@OUTPUT@', pmdinfogen],
+                                       output: out_filename,
+                                       depends: [pmdinfogen, tmp_lib])
 
                        if get_option('per_library_versions')
                                lib_version = '@0@.1'.format(version)
@@ -83,7 +109,6 @@ foreach class:driver_classes
                        endif
 
                        # now build the static driver
-                       lib_name = driver_name_fmt.format(name)
                        static_lib = static_library(lib_name,
                                sources,
                                objects: objs,
@@ -93,8 +118,6 @@ foreach class:driver_classes
                                install: true)
 
                        # now build the shared driver
-                       sources = []
-                       objs += static_lib.extract_all_objects()
                        version_map = '@0@/@1@/@2@_version.map'.format(
                                        meson.current_source_dir(),
                                        drv_path, lib_name)
@@ -126,4 +149,9 @@ foreach class:driver_classes
                        set_variable('static_@0@'.format(lib_name), static_dep)
                endif # build
        endforeach
+
+       if meson.version().version_compare('>=0.47')
+               # prior to 0.47, set_variable can't take array params
+               set_variable(class + '_drivers', class_drivers)
+       endif
 endforeach