mk: build with _GNU_SOURCE defined by default
[dpdk.git] / drivers / meson.build
index c5df313..567f4a1 100644 (file)
@@ -9,12 +9,17 @@ driver_classes = ['common',
               'crypto',  # depends on common, bus and mempool (net in future).
               'compress', # depends on common, bus, mempool.
               'event',   # depends on common, bus, mempool and net.
+              'baseband', # depends on common and bus.
               'raw']     # depends on common, bus, mempool, net and event.
 
 default_cflags = machine_args
 if cc.has_argument('-Wno-format-truncation')
        default_cflags += '-Wno-format-truncation'
 endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
+
 foreach class:driver_classes
        drivers = []
        std_deps = []