mbuf: extend meaning of QinQ stripped bit
[dpdk.git] / drivers / meson.build
index 161cfda..5f95265 100644 (file)
@@ -1,17 +1,21 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017-2019 Intel Corporation
 
-# Defines the order in which the drivers are buit.
-dpdk_driver_classes = ['common',
-              'bus',
-              'mempool', # depends on common and bus.
-              'net',     # depends on common, bus, mempool
-              'raw',     # depends on common, bus and net.
-              'crypto',  # depends on common, bus and mempool (net in future).
-              'compress', # depends on common, bus, mempool.
-              'vdpa',    # depends on common, bus and mempool.
-              'event',   # depends on common, bus, mempool and net.
-              'baseband'] # depends on common and bus.
+# Defines the order of dependencies evaluation
+subdirs = [
+       'common',
+       'bus',
+       'common/mlx5', # depends on bus.
+       'mempool', # depends on common and bus.
+       'net',     # depends on common, bus, mempool
+       'raw',     # depends on common, bus and net.
+       'crypto',  # depends on common, bus and mempool (net in future).
+       'compress', # depends on common, bus, mempool.
+       'regex', # depends on common, bus, regexdev.
+       'vdpa',    # depends on common, bus and mempool.
+       'event',   # depends on common, bus, mempool and net.
+       'baseband', # depends on common and bus.
+]
 
 disabled_drivers = run_command(list_dir_globs, get_option('disable_drivers'),
                ).stdout().split()
@@ -24,7 +28,7 @@ if cc.has_argument('-Wno-format-truncation')
        default_cflags += '-Wno-format-truncation'
 endif
 
-foreach class:dpdk_driver_classes
+foreach subpath:subdirs
        drivers = []
        std_deps = []
        config_flag_fmt = '' # format string used to set the value in dpdk_conf
@@ -32,8 +36,22 @@ foreach class:dpdk_driver_classes
                             # the library, the dependency and to find the
                             # version file for linking
 
-       subdir(class)
-       class_drivers = []
+       # subpath can be either "class" or "class/driver"
+       if subpath.contains('/')
+               driver_path = subpath.split('/')
+               class = driver_path[0]
+               drivers += driver_path[1]
+       else
+               class = subpath
+               subdir(class)
+       endif
+
+       # save class name on first occurrence
+       if not dpdk_driver_classes.contains(class)
+               dpdk_driver_classes += class
+       endif
+       # get already enabled drivers of the same class
+       enabled_drivers = get_variable(class + '_drivers', [])
 
        foreach drv:drivers
                drv_path = join_paths(class, drv)
@@ -93,7 +111,7 @@ foreach class:dpdk_driver_classes
                                                '_disable_reason', reason)
                        endif
                else
-                       class_drivers += name
+                       enabled_drivers += name
 
                        if fmt_name == ''
                                fmt_name = name
@@ -200,5 +218,5 @@ foreach class:dpdk_driver_classes
                endif # build
        endforeach
 
-       set_variable(class + '_drivers', class_drivers)
+       set_variable(class + '_drivers', enabled_drivers)
 endforeach