test mbuf attach
[dpdk.git] / drivers / meson.build
index 6ce2d6b..5f95265 100644 (file)
@@ -1,21 +1,21 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017-2019 Intel Corporation
 
-if is_windows
-       subdir_done()
-endif
-
-# Defines the order in which the drivers are buit.
-dpdk_driver_classes = ['common',
-              'bus',
-              'mempool', # depends on common and bus.
-              'net',     # depends on common, bus, mempool
-              'raw',     # depends on common, bus and net.
-              'crypto',  # depends on common, bus and mempool (net in future).
-              'compress', # depends on common, bus, mempool.
-              'vdpa',    # depends on common, bus and mempool.
-              'event',   # depends on common, bus, mempool and net.
-              'baseband'] # depends on common and bus.
+# Defines the order of dependencies evaluation
+subdirs = [
+       'common',
+       'bus',
+       'common/mlx5', # depends on bus.
+       'mempool', # depends on common and bus.
+       'net',     # depends on common, bus, mempool
+       'raw',     # depends on common, bus and net.
+       'crypto',  # depends on common, bus and mempool (net in future).
+       'compress', # depends on common, bus, mempool.
+       'regex', # depends on common, bus, regexdev.
+       'vdpa',    # depends on common, bus and mempool.
+       'event',   # depends on common, bus, mempool and net.
+       'baseband', # depends on common and bus.
+]
 
 disabled_drivers = run_command(list_dir_globs, get_option('disable_drivers'),
                ).stdout().split()
@@ -28,7 +28,7 @@ if cc.has_argument('-Wno-format-truncation')
        default_cflags += '-Wno-format-truncation'
 endif
 
-foreach class:dpdk_driver_classes
+foreach subpath:subdirs
        drivers = []
        std_deps = []
        config_flag_fmt = '' # format string used to set the value in dpdk_conf
@@ -36,8 +36,22 @@ foreach class:dpdk_driver_classes
                             # the library, the dependency and to find the
                             # version file for linking
 
-       subdir(class)
-       class_drivers = []
+       # subpath can be either "class" or "class/driver"
+       if subpath.contains('/')
+               driver_path = subpath.split('/')
+               class = driver_path[0]
+               drivers += driver_path[1]
+       else
+               class = subpath
+               subdir(class)
+       endif
+
+       # save class name on first occurrence
+       if not dpdk_driver_classes.contains(class)
+               dpdk_driver_classes += class
+       endif
+       # get already enabled drivers of the same class
+       enabled_drivers = get_variable(class + '_drivers', [])
 
        foreach drv:drivers
                drv_path = join_paths(class, drv)
@@ -97,7 +111,7 @@ foreach class:dpdk_driver_classes
                                                '_disable_reason', reason)
                        endif
                else
-                       class_drivers += name
+                       enabled_drivers += name
 
                        if fmt_name == ''
                                fmt_name = name
@@ -125,20 +139,6 @@ foreach class:dpdk_driver_classes
                                                output: out_filename,
                                                depends: [pmdinfogen, tmp_lib])
                        endif
-                       version_map = '@0@/@1@/@2@_version.map'.format(
-                                       meson.current_source_dir(),
-                                       drv_path, lib_name)
-
-                       is_stable = run_command(is_stable_cmd,
-                               files(version_map)).returncode() == 0
-
-                       if is_stable
-                               lib_version = abi_version
-                               so_version = stable_so_version
-                       else
-                               lib_version = experimental_abi_version
-                               so_version = experimental_so_version
-                       endif
 
                        # now build the static driver
                        static_lib = static_library(lib_name,
@@ -153,16 +153,26 @@ foreach class:dpdk_driver_classes
                        version_map = '@0@/@1@/@2@_version.map'.format(
                                        meson.current_source_dir(),
                                        drv_path, lib_name)
-                       implib = dir_name + '.dll.a'
+                       implib = 'lib' + lib_name + '.dll.a'
 
                        def_file = custom_target(lib_name + '_def',
-                               command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
+                               command: [map_to_win_cmd, '@INPUT@', '@OUTPUT@'],
                                input: version_map,
                                output: '@0@_exports.def'.format(lib_name))
-                       lk_deps = [version_map, def_file]
+
+                       mingw_map = custom_target(lib_name + '_mingw',
+                               command: [map_to_win_cmd, '@INPUT@', '@OUTPUT@'],
+                               input: version_map,
+                               output: '@0@_mingw.map'.format(lib_name))
+
+                       lk_deps = [version_map, def_file, mingw_map]
                        if is_windows
-                               lk_args = ['-Wl,/def:' + def_file.full_path(),
-                                       '-Wl,/implib:lib\\' + implib]
+                               if is_ms_linker
+                                       lk_args = ['-Wl,/def:' + def_file.full_path(),
+                                               '-Wl,/implib:drivers\\' + implib]
+                               else
+                                       lk_args = ['-Wl,--version-script=' + mingw_map.full_path()]
+                               endif
                        else
                                lk_args = ['-Wl,--version-script=' + version_map]
                                # on unix systems check the output of the
@@ -184,7 +194,7 @@ foreach class:dpdk_driver_classes
                                c_args: cflags,
                                link_args: lk_args,
                                link_depends: lk_deps,
-                               version: lib_version,
+                               version: abi_version,
                                soversion: so_version,
                                install: true,
                                install_dir: driver_install_path)
@@ -194,7 +204,7 @@ foreach class:dpdk_driver_classes
                        shared_dep = declare_dependency(link_with: shared_lib,
                                        include_directories: includes,
                                        dependencies: shared_deps)
-                       static_dep = declare_dependency(link_with: static_lib,
+                       static_dep = declare_dependency(
                                        include_directories: includes,
                                        dependencies: static_deps)
 
@@ -208,5 +218,5 @@ foreach class:dpdk_driver_classes
                endif # build
        endforeach
 
-       set_variable(class + '_drivers', class_drivers)
+       set_variable(class + '_drivers', enabled_drivers)
 endforeach