build: change ABI versioning to global
[dpdk.git] / drivers / meson.build
index ec81917..72eec46 100644 (file)
@@ -9,12 +9,14 @@ endif
 dpdk_driver_classes = ['common',
               'bus',
               'mempool', # depends on common and bus.
-              'net',     # depends on common, bus and mempool.
+              'raw',     # depends on common and bus.
+              'net',     # depends on common, bus, mempool and raw.
               'crypto',  # depends on common, bus and mempool (net in future).
               'compress', # depends on common, bus, mempool.
               'event',   # depends on common, bus, mempool and net.
-              'baseband', # depends on common and bus.
-              'raw']     # depends on common, bus, mempool, net and event.
+              'baseband'] # depends on common and bus.
+
+disabled_drivers = get_option('disable_drivers').split(',')
 
 default_cflags = machine_args
 if cc.has_argument('-Wno-format-truncation')
@@ -39,7 +41,6 @@ foreach class:dpdk_driver_classes
                build = true # set to false to disable, e.g. missing deps
                reason = '<unknown reason>' # set if build == false to explain
                name = drv
-               version = 1
                allow_experimental_apis = false
                sources = []
                objs = []
@@ -59,6 +60,31 @@ foreach class:dpdk_driver_classes
                # pull in driver directory which should assign to each of the above
                subdir(drv_path)
 
+               # skip disabled drivers. For meson 0.49 change this to use
+               # "in" keyword
+               foreach disable_path: disabled_drivers
+                       if drv_path == disable_path
+                               build = false
+                               reason = 'Explicitly disabled via build config'
+                       endif
+               endforeach
+               if build
+                       # get dependency objs from strings
+                       shared_deps = ext_deps
+                       static_deps = ext_deps
+                       foreach d:deps
+                               if not is_variable('shared_rte_' + d)
+                                       build = false
+                                       reason = 'Missing internal dependency, "@0@"'.format(d)
+                                       message('Disabling @1@ [@2@]: missing internal dependency "@0@"'
+                                                       .format(d, name, 'drivers/' + drv_path))
+                               else
+                                       shared_deps += [get_variable('shared_rte_' + d)]
+                                       static_deps += [get_variable('static_rte_' + d)]
+                               endif
+                       endforeach
+               endif
+
                if not build
                        # some driver directories are placeholders which
                        # are never built, so we allow suppression of the
@@ -78,19 +104,6 @@ foreach class:dpdk_driver_classes
                                cflags += '-DALLOW_EXPERIMENTAL_API'
                        endif
 
-                       # get dependency objs from strings
-                       shared_deps = []
-                       static_deps = []
-                       foreach d:deps
-                               if not is_variable('shared_rte_' + d)
-                                       error('Missing dependency ' + d +
-                                               ' for driver ' + lib_name)
-                               endif
-                               shared_deps += [get_variable('shared_rte_' + d)]
-                               static_deps += [get_variable('static_rte_' + d)]
-                       endforeach
-                       shared_deps += ext_deps
-                       static_deps += ext_deps
                        dpdk_extra_ldflags += pkgconfig_extra_libs
 
                        # generate pmdinfo sources by building a temporary
@@ -110,12 +123,19 @@ foreach class:dpdk_driver_classes
                                        output: out_filename,
                                        depends: [pmdinfogen, tmp_lib])
 
-                       if get_option('per_library_versions')
-                               lib_version = '@0@.1'.format(version)
-                               so_version = '@0@'.format(version)
+                       version_map = '@0@/@1@/@2@_version.map'.format(
+                                       meson.current_source_dir(),
+                                       drv_path, lib_name)
+
+                       is_experimental = run_command(is_experimental_cmd,
+                               files(version_map)).returncode()
+
+                       if is_experimental != 0
+                               lib_version = experimental_abi_version
+                               so_version = experimental_abi_version
                        else
-                               lib_version = major_version
-                               so_version = major_version
+                               lib_version = abi_version
+                               so_version = abi_version
                        endif
 
                        # now build the static driver
@@ -131,14 +151,37 @@ foreach class:dpdk_driver_classes
                        version_map = '@0@/@1@/@2@_version.map'.format(
                                        meson.current_source_dir(),
                                        drv_path, lib_name)
+                       implib = dir_name + '.dll.a'
+
+                       def_file = custom_target(lib_name + '_def',
+                               command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
+                               input: version_map,
+                               output: '@0@_exports.def'.format(lib_name))
+                       lk_deps = [version_map, def_file]
+                       if is_windows
+                               lk_args = ['-Wl,/def:' + def_file.full_path(),
+                                       '-Wl,/implib:lib\\' + implib]
+                       else
+                               lk_args = ['-Wl,--version-script=' + version_map]
+                               # on unix systems check the output of the
+                               # experimental syms script, using it as a
+                               # dependency of the .so build
+                               lk_deps += custom_target(lib_name + '.exp_chk',
+                                       command: [check_experimental_syms,
+                                               version_map, '@INPUT@'],
+                                       capture: true,
+                                       input: static_lib,
+                                       output: lib_name + '.exp_chk')
+                       endif
+
                        shared_lib = shared_library(lib_name,
                                sources,
                                objects: objs,
                                include_directories: includes,
                                dependencies: shared_deps,
                                c_args: cflags,
-                               link_args: '-Wl,--version-script=' + version_map,
-                               link_depends: version_map,
+                               link_args: lk_args,
+                               link_depends: lk_deps,
                                version: lib_version,
                                soversion: so_version,
                                install: true,