build: replace license text with SPDX tag
[dpdk.git] / drivers / meson.build
index 50ba3a3..f6680ce 100644 (file)
@@ -1,35 +1,7 @@
-#   BSD LICENSE
-#
-#   Copyright(c) 2017 Intel Corporation.
-#   All rights reserved.
-#
-#   Redistribution and use in source and binary forms, with or without
-#   modification, are permitted provided that the following conditions
-#   are met:
-#
-#     * Redistributions of source code must retain the above copyright
-#       notice, this list of conditions and the following disclaimer.
-#     * Redistributions in binary form must reproduce the above copyright
-#       notice, this list of conditions and the following disclaimer in
-#       the documentation and/or other materials provided with the
-#       distribution.
-#     * Neither the name of Intel Corporation nor the names of its
-#       contributors may be used to endorse or promote products derived
-#       from this software without specific prior written permission.
-#
-#   THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-#   "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-#   LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-#   A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-#   OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-#   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-#   DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-#   THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-#   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-#   OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-driver_classes = ['bus']
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+driver_classes = ['bus', 'crypto', 'event', 'mempool', 'net']
 
 foreach class:driver_classes
        drivers = []
@@ -46,6 +18,7 @@ foreach class:driver_classes
 
                # set up empty variables used for build
                build = true # set to false to disable, e.g. missing deps
+               name = drv
                version = 1
                allow_experimental_apis = false
                sources = []
@@ -66,18 +39,21 @@ foreach class:driver_classes
                subdir(drv_path)
 
                if build
-                       dpdk_conf.set(config_flag_fmt.format(drv.to_upper()),1)
+                       dpdk_conf.set(config_flag_fmt.format(name.to_upper()),1)
 
                        if allow_experimental_apis
                                cflags += '-DALLOW_EXPERIMENTAL_API'
                        endif
 
                        # get dependency objs from strings
-                       dep_objs = []
+                       shared_objs = []
+                       static_objs = []
                        foreach d:deps
-                               dep_objs += [get_variable('dep_rte_' + d)]
+                               shared_objs += [get_variable('shared_rte_' + d)]
+                               static_objs += [get_variable('static_rte_' + d)]
                        endforeach
-                       dep_objs += ext_deps
+                       shared_objs += ext_deps
+                       static_objs += ext_deps
                        dpdk_extra_ldflags += pkgconfig_extra_libs
 
                        # generate pmdinfo sources
@@ -87,7 +63,7 @@ foreach class:driver_classes
                                out_filename = '@0@.pmd.c'.format(src.split('/')[-1])
                                tmp_lib = static_library('tmp_@0@'.format(src.underscorify()),
                                        src, include_directories: includes,
-                                       dependencies: dep_objs,
+                                       dependencies: static_objs,
                                        c_args: cflags)
                                sources += custom_target(out_filename,
                                                command: [pmdinfo, tmp_lib.full_path(),
@@ -96,31 +72,58 @@ foreach class:driver_classes
                                                depends: [pmdinfogen, tmp_lib])
                        endforeach
 
-                       # now build the driver itself, and add to the drivers list
-                       drv_name = driver_name_fmt.format(drv)
+                       if get_option('per_library_versions')
+                               lib_version = '@0@.1'.format(version)
+                               so_version = '@0@'.format(version)
+                       else
+                               pver = meson.project_version().split('.')
+                               lib_version = '@0@.@1@'.format(pver.get(0),
+                                               pver.get(1))
+                               so_version = lib_version
+                       endif
+
+                       # now build the static driver
+                       lib_name = driver_name_fmt.format(name)
+                       static_lib = static_library(lib_name,
+                               sources,
+                               objects: objs,
+                               include_directories: includes,
+                               dependencies: static_objs,
+                               c_args: cflags,
+                               install: true)
+
+                       # now build the shared driver
+                       sources = []
+                       objs += static_lib.extract_all_objects()
                        version_map = '@0@/@1@/@2@_version.map'.format(
                                        meson.current_source_dir(),
-                                       drv_path, drv_name)
-                       lib = library(drv_name,
+                                       drv_path, lib_name)
+                       shared_lib = shared_library(lib_name,
                                sources,
                                objects: objs,
                                include_directories: includes,
-                               dependencies: dep_objs,
+                               dependencies: shared_objs,
                                c_args: cflags,
                                link_args: '-Wl,--version-script=' + version_map,
                                link_depends: version_map,
-                               version: '@0@.1'.format(version),
+                               version: lib_version,
+                               soversion: so_version,
                                install: true,
                                install_dir: driver_install_path)
 
-                       dpdk_drivers += lib
-
                        # create a dependency object and add it to the global dictionary so
                        # testpmd or other built-in apps can find it if necessary
-                       set_variable('dep_@0@'.format(drv_name),
-                                       declare_dependency(link_with: lib,
+                       shared_dep = declare_dependency(link_with: shared_lib,
                                        include_directories: includes,
-                                       dependencies: dep_objs))
+                                       dependencies: shared_objs)
+                       static_dep = declare_dependency(link_with: static_lib,
+                                       include_directories: includes,
+                                       dependencies: static_objs)
+
+                       dpdk_drivers += static_lib
+
+                       set_variable('shared_@0@'.format(lib_name), shared_dep)
+                       set_variable('static_@0@'.format(lib_name), static_dep)
                endif # build
        endforeach
 endforeach