net/bnxt: add TruFlow hash function
[dpdk.git] / drivers / net / bnxt / meson.build
index 54564e0..190469e 100644 (file)
@@ -31,7 +31,6 @@ sources = files('bnxt_cpr.c',
         'tf_core/tf_em_common.c',
         'tf_core/tf_em_host.c',
         'tf_core/tf_em_internal.c',
-        'tf_core/tf_em_system.c',
        'tf_core/tf_rm.c',
        'tf_core/tf_tbl.c',
        'tf_core/tfp.c',
@@ -45,6 +44,10 @@ sources = files('bnxt_cpr.c',
        'tf_core/tf_util.c',
        'tf_core/tf_if_tbl.c',
        'tf_core/ll.c',
+       'tf_core/tf_global_cfg.c',
+       'tf_core/tf_em_host.c',
+       'tf_core/tf_shadow_identifier.c',
+       'tf_core/tf_hash.c',
 
        'hcapi/hcapi_cfa_p4.c',
 
@@ -60,9 +63,13 @@ sources = files('bnxt_cpr.c',
        'tf_ulp/ulp_rte_parser.c',
        'tf_ulp/bnxt_ulp_flow.c',
        'tf_ulp/ulp_port_db.c',
+       'tf_ulp/ulp_def_rules.c',
+       'tf_ulp/ulp_fc_mgr.c',
 
        'rte_pmd_bnxt.c')
 
 if arch_subdir == 'x86'
        sources += files('bnxt_rxtx_vec_sse.c')
+elif arch_subdir == 'arm' and host_machine.cpu_family().startswith('aarch64')
+       sources += files('bnxt_rxtx_vec_neon.c')
 endif