net/bnxt: add port representor infrastructure
[dpdk.git] / drivers / net / bnxt / meson.build
index d75f887..5c7859c 100644 (file)
@@ -21,6 +21,7 @@ sources = files('bnxt_cpr.c',
        'bnxt_txr.c',
        'bnxt_util.c',
        'bnxt_vnic.c',
+       'bnxt_reps.c',
 
        'tf_core/tf_core.c',
        'tf_core/bitalloc.c',
@@ -35,12 +36,15 @@ sources = files('bnxt_cpr.c',
        'tf_ulp/bnxt_ulp.c',
        'tf_ulp/ulp_mark_mgr.c',
        'tf_ulp/ulp_flow_db.c',
-       'tf_ulp/ulp_template_db.c',
+       'tf_ulp/ulp_template_db_tbl.c',
+       'tf_ulp/ulp_template_db_class.c',
+       'tf_ulp/ulp_template_db_act.c',
        'tf_ulp/ulp_utils.c',
        'tf_ulp/ulp_mapper.c',
        'tf_ulp/ulp_matcher.c',
        'tf_ulp/ulp_rte_parser.c',
        'tf_ulp/bnxt_ulp_flow.c',
+       'tf_ulp/ulp_port_db.c',
 
        'rte_pmd_bnxt.c')