net/bnxt: add ULP flow counter manager
[dpdk.git] / drivers / net / bnxt / meson.build
index 54564e0..5fb0ed3 100644 (file)
@@ -31,7 +31,6 @@ sources = files('bnxt_cpr.c',
         'tf_core/tf_em_common.c',
         'tf_core/tf_em_host.c',
         'tf_core/tf_em_internal.c',
-        'tf_core/tf_em_system.c',
        'tf_core/tf_rm.c',
        'tf_core/tf_tbl.c',
        'tf_core/tfp.c',
@@ -45,6 +44,9 @@ sources = files('bnxt_cpr.c',
        'tf_core/tf_util.c',
        'tf_core/tf_if_tbl.c',
        'tf_core/ll.c',
+       'tf_core/tf_global_cfg.c',
+       'tf_core/tf_em_host.c',
+       'tf_ulp/ulp_fc_mgr.c',
 
        'hcapi/hcapi_cfa_p4.c',
 
@@ -60,6 +62,7 @@ sources = files('bnxt_cpr.c',
        'tf_ulp/ulp_rte_parser.c',
        'tf_ulp/bnxt_ulp_flow.c',
        'tf_ulp/ulp_port_db.c',
+       'tf_ulp/ulp_def_rules.c',
 
        'rte_pmd_bnxt.c')