common/mlx5: remove NDEBUG
[dpdk.git] / drivers / net / mlx5 / meson.build
index d45be00..d418d26 100644 (file)
@@ -49,7 +49,7 @@ foreach option:cflags_options
        endif
 endforeach
 if get_option('buildtype').contains('debug')
-       cflags += [ '-pedantic', '-UNDEBUG', '-DPEDANTIC' ]
+       cflags += [ '-pedantic', '-DPEDANTIC' ]
 else
-       cflags += [ '-DNDEBUG', '-UPEDANTIC' ]
+       cflags += [ '-UPEDANTIC' ]
 endif