net/mlx5: add Linux-specific file with getter functions
[dpdk.git] / drivers / net / mlx5 / meson.build
index 928663a..e71b2c5 100644 (file)
@@ -2,9 +2,9 @@
 # Copyright 2018 6WIND S.A.
 # Copyright 2018 Mellanox Technologies, Ltd
 
-if not is_linux
+if not (is_linux or is_windows)
        build = false
-       reason = 'only supported on Linux'
+       reason = 'only supported on Linux and Windows'
        subdir_done()
 endif
 
@@ -52,3 +52,4 @@ if get_option('buildtype').contains('debug')
 else
        cflags += [ '-UPEDANTIC' ]
 endif
+subdir(exec_env)