build: replace meson OS detection with variable
[dpdk.git] / drivers / net / pfe / meson.build
index 3e1a228..da0787c 100644 (file)
@@ -1,8 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright 2019 NXP
 
-if host_machine.system() != 'linux'
+if not is_linux
        build = false
+       reason = 'only supported on Linux'
 endif
 deps += ['common_dpaax']