build: replace meson OS detection with variable
[dpdk.git] / drivers / net / pfe / meson.build
index 799500b..da0787c 100644 (file)
@@ -1,10 +1,11 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright 2019 NXP
 
-if host_machine.system() != 'linux'
+if not is_linux
        build = false
+       reason = 'only supported on Linux'
 endif
-deps += ['bus_dpaa']
+deps += ['common_dpaax']
 
 sources = files('pfe_ethdev.c',
                'pfe_hal.c',
@@ -15,9 +16,4 @@ if cc.has_argument('-Wno-pointer-arith')
        cflags += '-Wno-pointer-arith'
 endif
 
-# Driver uses below experimental APIs
-# rte_mem_iova2virt
-# rte_mem_virt2memseg
-allow_experimental_apis = true
-
 includes += include_directories('base')