eal: add telemetry as dependency
[dpdk.git] / examples / l3fwd-power / meson.build
index 2c84123..4cd6947 100644 (file)
@@ -6,11 +6,13 @@
 # To build this example as a standalone application with an already-installed
 # DPDK instance, use 'make'
 
-if not is_linux
-       build = false
+if not dpdk_conf.has('RTE_LIBRTE_POWER')
+        build = false
+        subdir_done()
 endif
+
 allow_experimental_apis = true
-deps += ['power', 'timer', 'lpm', 'hash']
+deps += ['power', 'timer', 'lpm', 'hash', 'metrics', 'telemetry']
 sources = files(
        'main.c', 'perf_core.c'
 )