test/ipsec: fix a typo in function name
[dpdk.git] / examples / meson.build
index a6acda7..1f2b6f5 100644 (file)
@@ -11,15 +11,16 @@ execinfo = cc.find_library('execinfo', required: false)
 # list of all example apps. Keep 1-3 per line, in alphabetical order.
 all_examples = [
        'bbdev_app', 'bond',
-       'bpf', 'cmdline',
+       'cmdline',
        'distributor', 'ethtool',
        'eventdev_pipeline',
        'fips_validation', 'flow_classify',
        'flow_filtering', 'helloworld',
+       'ioat',
        'ip_fragmentation', 'ip_pipeline',
        'ip_reassembly', 'ipsec-secgw',
        'ipv4_multicast', 'kni',
-       'l2fwd', 'l2fwd-cat',
+       'l2fwd', 'l2fwd-cat', 'l2fwd-event',
        'l2fwd-crypto', 'l2fwd-jobstats',
        'l2fwd-keepalive', 'l3fwd',
        'l3fwd-acl', 'l3fwd-power',
@@ -30,14 +31,19 @@ all_examples = [
        'multi_process/simple_mp',
        'multi_process/symmetric_mp',
        'ntb', 'packet_ordering',
-       'performance-thread', 'ptpclient',
+       'performance-thread/l3fwd-thread',
+       'performance-thread/pthread_shim',
+       'ptpclient',
        'qos_meter', 'qos_sched',
        'rxtx_callbacks',
-       'server_node_efd', 'service_cores',
+       'server_node_efd/node',
+       'server_node_efd/server',
+       'service_cores',
        'skeleton', 'tep_termination',
        'timer', 'vdpa',
        'vhost', 'vhost_crypto',
-       'vm_power_manager',
+       'vhost_blk', 'vm_power_manager',
+       'vm_power_manager/guest_cli',
        'vmdq', 'vmdq_dcb',
 ]
 # install all example code on install - irrespective of whether the example in