test mbuf attach
[dpdk.git] / examples / meson.build
index a046b74..eb13e82 100644 (file)
@@ -1,9 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017-2019 Intel Corporation
 
-driver_libs = []
+link_whole_libs = []
 if get_option('default_library') == 'static'
-       driver_libs = dpdk_drivers
+       link_whole_libs = dpdk_static_libraries + dpdk_drivers
 endif
 
 execinfo = cc.find_library('execinfo', required: false)
@@ -11,34 +11,39 @@ execinfo = cc.find_library('execinfo', required: false)
 # list of all example apps. Keep 1-3 per line, in alphabetical order.
 all_examples = [
        'bbdev_app', 'bond',
-       'bpf', 'cmdline',
+       'cmdline',
        'distributor', 'ethtool',
-       'eventdev_pipeline', 'exception_path',
+       'eventdev_pipeline',
        'fips_validation', 'flow_classify',
        'flow_filtering', 'helloworld',
+       'ioat',
        'ip_fragmentation', 'ip_pipeline',
        'ip_reassembly', 'ipsec-secgw',
        'ipv4_multicast', 'kni',
-       'l2fwd', 'l2fwd-cat',
+       'l2fwd', 'l2fwd-cat', 'l2fwd-event',
        'l2fwd-crypto', 'l2fwd-jobstats',
        'l2fwd-keepalive', 'l3fwd',
-       'l3fwd-acl', 'l3fwd-power',
-       'l3fwd-vf', 'link_status_interrupt',
-       'load_balancer',
+       'l3fwd-acl', 'l3fwd-power', 'l3fwd-graph',
+       'link_status_interrupt',
        'multi_process/client_server_mp/mp_client',
        'multi_process/client_server_mp/mp_server',
        'multi_process/hotplug_mp',
        'multi_process/simple_mp',
        'multi_process/symmetric_mp',
-       'netmap_compat', 'ntb', 'packet_ordering',
-       'performance-thread', 'ptpclient',
+       'ntb', 'packet_ordering',
+       'performance-thread/l3fwd-thread',
+       'performance-thread/pthread_shim',
+       'ptpclient',
        'qos_meter', 'qos_sched',
-       'quota_watermark', 'rxtx_callbacks',
-       'server_node_efd', 'service_cores',
+       'rxtx_callbacks',
+       'server_node_efd/node',
+       'server_node_efd/server',
+       'service_cores',
        'skeleton', 'tep_termination',
        'timer', 'vdpa',
        'vhost', 'vhost_crypto',
-       'vhost_scsi', 'vm_power_manager',
+       'vhost_blk', 'vm_power_manager',
+       'vm_power_manager/guest_cli',
        'vmdq', 'vmdq_dcb',
 ]
 # install all example code on install - irrespective of whether the example in
@@ -94,7 +99,7 @@ foreach example: examples
                endif
                executable('dpdk-' + name, sources,
                        include_directories: includes,
-                       link_whole: driver_libs,
+                       link_whole: link_whole_libs,
                        link_args: dpdk_extra_ldflags,
                        c_args: cflags,
                        dependencies: dep_objs)