build: replace meson OS detection with variable
[dpdk.git] / examples / ntb / meson.build
index 9a6288f..45a5935 100644 (file)
@@ -6,7 +6,8 @@
 # To build this example as a standalone application with an already-installed
 # DPDK instance, use 'make'
 
-if host_machine.system() != 'linux'
+allow_experimental_apis = true
+if not is_linux
        build = false
 endif
 deps += 'rawdev'
@@ -14,3 +15,6 @@ cflags += ['-D_FILE_OFFSET_BITS=64']
 sources = files(
        'ntb_fwd.c'
 )
+if dpdk_conf.has('RTE_LIBRTE_PMD_NTB_RAWDEV')
+       deps += 'rawdev_ntb'
+endif