mk: build with _GNU_SOURCE defined by default
[dpdk.git] / examples / vhost_scsi / meson.build
index bd78e84..2303bca 100644 (file)
@@ -6,8 +6,11 @@
 # To build this example as a standalone application with an already-installed
 # DPDK instance, use 'make'
 
+if host_machine.system() != 'linux'
+       build = false
+endif
 deps += 'vhost'
-cflags += ['-D_GNU_SOURCE','-D_FILE_OFFSET_BITS=64']
+cflags += ['-D_FILE_OFFSET_BITS=64']
 sources = files(
        'scsi.c', 'vhost_scsi.c'
 )