eal: move common header files
[dpdk.git] / kernel / linux / kni / meson.build
index a9f48b0..706bea5 100644 (file)
@@ -13,17 +13,16 @@ kni_sources = files(
 custom_target('rte_kni',
        input: kni_sources,
        output: 'rte_kni.ko',
-       command: ['make', '-j4', '-C', kernel_dir,
+       command: ['make', '-j4', '-C', kernel_dir + '/build',
                'M=' + meson.current_build_dir(),
                'src=' + meson.current_source_dir(),
                'MODULE_CFLAGS=-include ' + meson.source_root() + '/config/rte_config.h' +
-               ' -I' + meson.source_root() + '/lib/librte_eal/common/include' +
+               ' -I' + meson.source_root() + '/lib/librte_eal/include' +
                ' -I' + meson.source_root() + '/lib/librte_eal/linux/eal/include' +
                ' -I' + meson.build_root() +
                ' -I' + meson.current_source_dir(),
                'modules'],
        depends: kni_mkfile,
-       console: true,
        install: true,
-       install_dir: kernel_dir + '/../extra/dpdk',
+       install_dir: kernel_dir + '/extra/dpdk',
        build_by_default: get_option('enable_kmods'))