build: add global libatomic dependency for 32-bit clang
[dpdk.git] / lib / librte_distributor / meson.build
index 266af64..bd12ddb 100644 (file)
@@ -9,8 +9,3 @@ else
 endif
 headers = files('rte_distributor.h')
 deps += ['mbuf']
-
-# for clang 32-bit compiles we need libatomic for 64-bit atomic ops
-if cc.get_id() == 'clang' and dpdk_conf.get('RTE_ARCH_64') == false
-       ext_deps += cc.find_library('atomic')
-endif