eal: move arch-specific header files
[dpdk.git] / lib / librte_eal / meson.build
index fa36b20..0c3d465 100644 (file)
@@ -12,13 +12,20 @@ subdir('common') # defines common_sources, common_objs, etc.
 dpdk_conf.set('RTE_EXEC_ENV_' + exec_env.to_upper(), 1)
 subdir(exec_env + '/eal')
 
-version = 10  # the version of the EAL API
+subdir(arch_subdir)
+
 allow_experimental_apis = true
 deps += 'kvargs'
 if dpdk_conf.has('RTE_USE_LIBBSD')
        ext_deps += libbsd
 endif
-sources = common_sources + env_sources
+if cc.has_function('getentropy', prefix : '#include <unistd.h>')
+       cflags += '-DRTE_LIBEAL_USE_GETENTROPY'
+endif
+if cc.has_header('getopt.h')
+       cflags += ['-DHAVE_GETOPT_H', '-DHAVE_GETOPT', '-DHAVE_GETOPT_LONG']
+endif
+sources += common_sources + env_sources
 objs = common_objs + env_objs
 headers = common_headers + env_headers
-includes = eal_inc
+includes += eal_inc