eal: move arch-specific C files
[dpdk.git] / lib / librte_eal / meson.build
index 0b6e65d..16a4f98 100644 (file)
@@ -12,7 +12,8 @@ subdir('common') # defines common_sources, common_objs, etc.
 dpdk_conf.set('RTE_EXEC_ENV_' + exec_env.to_upper(), 1)
 subdir(exec_env + '/eal')
 
-version = 12  # the version of the EAL API
+subdir(arch_subdir)
+
 allow_experimental_apis = true
 deps += 'kvargs'
 if dpdk_conf.has('RTE_USE_LIBBSD')
@@ -21,7 +22,10 @@ endif
 if cc.has_function('getentropy', prefix : '#include <unistd.h>')
        cflags += '-DRTE_LIBEAL_USE_GETENTROPY'
 endif
-sources = common_sources + env_sources
+if cc.has_header('getopt.h')
+       cflags += ['-DHAVE_GETOPT_H', '-DHAVE_GETOPT', '-DHAVE_GETOPT_LONG']
+endif
+sources += common_sources + env_sources
 objs = common_objs + env_objs
 headers = common_headers + env_headers
 includes = eal_inc