eal: move arch-specific C files
[dpdk.git] / lib / librte_eal / meson.build
index cb8d109..16a4f98 100644 (file)
@@ -1,5 +1,5 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
 
 # Custom EAL processing. EAL is complicated enough that it can't just
 # have a straight list of headers and source files.
@@ -9,25 +9,23 @@ subdir('common') # defines common_sources, common_objs, etc.
 
 # Now do OS/exec-env specific settings, including building kernel modules
 # The <exec-env>/eal/meson.build file should define env_sources, etc.
-if host_machine.system() == 'linux'
-       dpdk_conf.set('RTE_EXEC_ENV_LINUXAPP', 1)
-       subdir('linux/eal')
+dpdk_conf.set('RTE_EXEC_ENV_' + exec_env.to_upper(), 1)
+subdir(exec_env + '/eal')
 
-elif host_machine.system() == 'freebsd'
-       dpdk_conf.set('RTE_EXEC_ENV_BSDAPP', 1)
-       subdir('freebsd/eal')
+subdir(arch_subdir)
 
-else
-       error('unsupported system type "@0@"'.format(host_machine.system()))
-endif
-
-version = 9  # the version of the EAL API
 allow_experimental_apis = true
 deps += 'kvargs'
 if dpdk_conf.has('RTE_USE_LIBBSD')
        ext_deps += libbsd
 endif
-sources = common_sources + env_sources
+if cc.has_function('getentropy', prefix : '#include <unistd.h>')
+       cflags += '-DRTE_LIBEAL_USE_GETENTROPY'
+endif
+if cc.has_header('getopt.h')
+       cflags += ['-DHAVE_GETOPT_H', '-DHAVE_GETOPT', '-DHAVE_GETOPT_LONG']
+endif
+sources += common_sources + env_sources
 objs = common_objs + env_objs
 headers = common_headers + env_headers
 includes = eal_inc