eal: move OS-specific sub-directories
[dpdk.git] / lib / librte_eal / meson.build
index 23ae03a..9d219a0 100644 (file)
@@ -1,18 +1,13 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017-2019 Intel Corporation
 
-# Custom EAL processing. EAL is complicated enough that it can't just
-# have a straight list of headers and source files.
-# Initially pull in common settings
-eal_inc = [global_inc]
+includes += global_inc
 subdir('include')
 
 subdir('common')
 
-# Now do OS/exec-env specific settings, including building kernel modules
-# The <exec-env>/eal/meson.build file should define env_sources, etc.
 dpdk_conf.set('RTE_EXEC_ENV_' + exec_env.to_upper(), 1)
-subdir(exec_env + '/eal')
+subdir(exec_env)
 
 subdir(arch_subdir)
 
@@ -27,7 +22,3 @@ endif
 if cc.has_header('getopt.h')
        cflags += ['-DHAVE_GETOPT_H', '-DHAVE_GETOPT', '-DHAVE_GETOPT_LONG']
 endif
-sources += env_sources
-objs = env_objs
-headers += env_headers
-includes += eal_inc